V-Twin Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter · #1 ·
just installed white bros e series slip ons on my 03 (carb)flhtc. rejetted to 46 slow shimmed the needle. exhaust popping on decel every time and constantly. tried 48 slow and 3 different needles and hasn't changed. replaced intake gaskets when I rejetted to be on the safe side. any suggestions. thks.
 

·
Registered
Joined
·
68 Posts
Did you adjust your micture screw? Bottom of the carb, towards the engine, drill it out, then take it all the way in , carefully, then back it out 2 1/2 turns, adjust from there till smooth.
Gary
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #3 ·
Gary, I've done it all except drill the port. I'm used to running mikunis and can have one dialed in pretty quick. I'd put a mik on but want to add the cruise. I've got a couple of cv's laying around with drilled out vac ports and might try this. thks
 

·
Registered
Joined
·
1,893 Posts
HAVE YOU TRIED A SMALLER PILOT JET? OR MAKE SURE YOUR CHOKE IS RETURNING TO THE FUULY SEATED POSITION. SOMETIMES THE CABLE WILL STICK.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #5 ·
I've done checked it all. even double checked the intake manifold gaskets. gonna use an extra slide I have with the port drilled and a dynojet needle and spring and see what happens. thks
 

·
Registered
Joined
·
2,300 Posts
Could be rich, could be reversion.

How many discs are you running?

You should try running as many as you need on the right side and very few on the left side, 4 or even less. With the closed end caps.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #7 ·
I was running 12 on the left and 12 on the right. I'll try running 3 or 4 on the left and maybe 14 on the right. my plugs did look a little rich, but the bike didn't feel rich. thks.
 

·
Registered
Joined
·
2,300 Posts
It's not unusual to have to lean the bike out a bit when going to 2 into 1's, particularly in the low midrange. It also minimizes the torque dip.
 

·
Registered
Joined
·
130 Posts
Truckman, If your bike is an "88, you need to remove some discs on the left side. Try running 12-14 on the right and 3 on the left. This is the set up I had on my bike before I added the big bore goodies this month. Bike ran very strong with only a little decel popping.

I don't think you will ever totally eliminate all the popping From what I've followed on these forums, most people never do. I got it down to a reasonable level on my FI bike by adjusting the Power Commander, but still had some.
Ken
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #10 ·
OK. still can't get it to stop popping. wouldn't bother me if it was occasional. but it's constant. running 46 slow 2 3/4 turns out on the mixture (best idle). sportster (88needle) and 190 main. 4 discs on the left anf 14 on the right. Is this a commom problem with White bros slip ons? should I not run any discs on the left? I talked to a tech at white bros and he said it is not good to run left side with no discs because of heat. I don't know. I hate to pull them off as I spent nearly 400 bucks for them, but I'm not gonna ride around with a popping exhaust. even pops when I shift occasionally. never had this problem with any other exhaust.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #11 ·
ya know. I think (know) my answer is a 2 into 1. I KNEW I should have put one on from the start. thought I'd try and keep the dual look. I KNEW IT, I KNEW IT, I KNEW IT !!!!!!!
 
1 - 11 of 11 Posts
Top