V-Twin Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
600 Posts
Discussion Starter · #1 ·
I purchased a 2003 silver and black VROD back in October, after 200 miles I noticed an oil leak in the rear of the left cam cover. I took it back to the dealer and they replaced the gaskets. it seemed to be fine for a while but at 500 miles the leak was back and worse than before. Took it back to the dealer and am now waiting to hear back. I was told that they had several people take in their VRODs for the same problem. Factory defect? If it happens again I'll be asking for a replacement. I can't seem to find the old posts on the subject (or am just too lazy to). So is anyone else out there experiencing the same problem. Hopefully not but please let me know if you are and what you have done or are doing about it. Thanks.
 

·
Registered
Joined
·
299 Posts
Mine made four trips in and finally ended up with a new cover and I think Harley OKed the use of Yamabond or a sealer like it to stop my rear valve cover from leaking. That was 1200 miles ago and still dry now. Tech said they also told him to sand the chrome off of the bottom of the cover.
 

·
Registered
Joined
·
122 Posts
Same leak, new cam covers. Next was a coolant leak, new heads. Another coolant leak, new water pump. I love my ride, but I was hoping it would provide ammunition to fight those leaky HD jokes. It's dry today.
 

·
Registered
Joined
·
600 Posts
Discussion Starter · #5 ·
Sad to hear that it seems to be a common problem. Just checked with the dealer and they just ordered a new cam cover. I'll keep an eye out for that coolant leak. Thanks everyone.
 
1 - 5 of 5 Posts
Top