V-Twin Forum banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
356 Posts
Discussion Starter · #1 ·
I have a set of bagger duals and the oval slip ons on my RKC. Had less than 100 miles on the bike, put a cam in, then took it to the dyno for a MAP. When I got the bike back, rear can was blued at the weld and gold color back and right can had tuned gold from the weld about half way back. Any one else have any problems with these. Called V&H and of course they blame everyone but themself. NO-GO on a replacement. I have gotten the blue off but the cans are still gold color. Any suggestions on clean up?

I am going back to the Dyno guy and see what he will do to replace them. Probably nothing, but it is beginning to chap my ass a little. This is my third set of V&H but no problems on the others.
Randy
 

·
Premium Member
Joined
·
356 Posts
Discussion Starter · #2 ·
Ooooooooops, meant to say less than 100 miles on the pipes.
 

·
Registered
Joined
·
18 Posts
Sounds like they put it through the ringer on the dyno.

Still no excuse for blued pipes. The only way to get away from that is an internally sleeved design. I am surprised the ovals did that....have never seen a set blue up. I have made my own sleeved bagger pipes....let me know if you are interested.
 

·
Premium Member
Joined
·
356 Posts
Discussion Starter · #5 ·
I talked with the dealer yesterday that did the dyno. He is going to replace them. No argument from him at all. They said they will take the fight to V&H. Now, that is a great dealer and they have earned my business for a long time to come.
Randy
 
1 - 5 of 5 Posts
Top