V-Twin Forum banner

1 - 20 of 43 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Im looking in to buying a Ultima 113 for my rigid, does anyone have experience with their quality? I dont want to have the same problems as the (JUNK) Revtec engines.
Thanks
 

·
Registered
Joined
·
313 Posts
I think you will be very happy with their 113 engine.Parts are high quality and there's some genuine motor company parts used as well.
John
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks, John. I need all the feed back I can get. Looks like my babys gettin a new engine.
 

·
Registered
Joined
·
1,893 Posts
I just talked to my local indy shop owner yesterday. The Ultima engines are made by Midwast, and they are made in the USA. They are manufactured in an effort to compete with the Rev-Tech engines, and are very competitively priced. Shop owner says they are a good motor and the price compared to S&S or the other big names is much lower. My next build will be based on one of them as well.
 

·
Registered
Joined
·
13 Posts
I have had the 100" on me softtail for about 2 months. the quality of the motor is great. i had a bad set of rocker box gaskets and they replaced them with no questions asked. the only complant i could have is the s&s carb that came with it i will be changing that out over the winter. the motor sound great and produces alot of horsepower.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks everyone. Im going to buy one after christmas. I ll let you guys know how it goes.
 

·
Registered
Joined
·
458 Posts
By what I'v heard about the quality of a RevTech I'd stick with a worn out HD, and rebuild it. You'd be a lot better off. They aren't known for quality control.
 

·
Registered
Joined
·
1 Posts
i own a shop in nj i have used over 30 ultima motors never had any problems. when they came out they used a lot of ss parts now they have all ther own everything in the motor is top of the line good luck i think you will be happy with your choice
 

·
Registered
Joined
·
9,250 Posts
CC - ya know, this is a 7-year-old thread...

LOL!! Been there and done that too! :whistle:

Glad to know about the good luck with Ultima motors none the less.
 

·
Registered
Joined
·
905 Posts
I have 127 el bruto in my springer.Runs strong.after some head work,more compreesion and new cam its making 155 hp and 147lbs tq.Dyno showed 120 plus tq from 2000 and until 6000.Ive had it 5 years and no problems.Not a ton of miles but I run the hell out of it.
 

·
Registered
Joined
·
5 Posts
broke ultima

Im looking in to buying a Ultima 113 for my rigid, does anyone have experience with their quality? I dont want to have the same problems as the (JUNK) Revtec engines.
Thanks
well had bought a 95 softtail, it came with 113 ultima,it had a thousand miles on it, i was told to put 2500 miles on before riding it hard, so i did, i was riding in town at 35 miles an hour, then all hell broke out, took it back to the shop i bought it from, he thought my primary shoe come lose, it did make alot of noise, but i still rode it to his shop,10 miles away, to his front door, long story short, my crank snap in half, they never heard of that to happen, so rebuild the motor, got it back on the road 50 miles later, i hear a grinding noise in the top end, ride it to the shop agin 10 miles or more, a lifter went bad on me, i have been told ultima was having a problem with the lifters, so we put a new cam & lifters in. my luck has not been good with this motor, now rocker boxes are leaking, the motor seems to make alot of noise, after what i have been threw, i worrie about break down. i guess i can say its a tough motor riding it with broke crank
 

·
Registered
Joined
·
5 Posts
:dh:
well had bought a 95 softtail, it came with 113 ultima,it had a thousand miles on it, i was told to put 2500 miles on before riding it hard, so i did, i was riding in town at 35 miles an hour, then all hell broke out, took it back to the shop i bought it from, he thought my primary shoe come lose, it did make alot of noise, but i still rode it to his shop,10 miles away, to his front door, long story short, my crank snap in half, they never heard of that to happen, so rebuild the motor, got it back on the road 50 miles later, i hear a grinding noise in the top end, ride it to the shop agin 10 miles or more, a lifter went bad on me, i have been told ultima was having a problem with the lifters, so we put a new cam & lifters in. my luck has not been good with this motor, now rocker boxes are leaking, the motor seems to make alot of noise, after what i have been threw, i worrie about break down. i guess i can say its a tough motor riding it with broke crank
we put in harley lifters, my motor is a 2006
 

·
Registered
Joined
·
5 Posts
broke ultima

:dh:
well had bought a 95 softtail, it came with 113 ultima,it had a thousand miles on it, i was told to put 2500 miles on before riding it hard, so i did, i was riding in town at 35 miles an hour, then all hell broke out, took it back to the shop i bought it from, he thought my primary shoe come lose, it did make alot of noise, but i still rode it to his shop,10 miles away, to his front door, long story short, my crank snap in half, they never heard of that to happen, so rebuild the motor, got it back on the road 50 miles later, i hear a grinding noise in the top end, ride it to the shop agin 10 miles or more, a lifter went bad on me, i have been told ultima was having a problem with the lifters, so we put a new cam & lifters in. my luck has not been good with this motor, now rocker boxes are leaking, the motor seems to make alot of noise, after what i have been threw, i worrie about break down. i guess i can say its a tough motor riding it with broke crank
we put in harley lifters, my motor is a 2006
 

·
Registered
Joined
·
32 Posts
I own an El Bruto 113...sits in the frame of a 95 dyna...
and only issue I've had is the stator disintegrated on me...
the magnets unattached...remarkably the engine would start and run
but once battery drained it was all stop..took a while to realize what happened.
And once identified and stator replaced no issues...starts and runs great...
you will need a hi-torque starter & a good battery and need to remember your
compression releases when the thing is hot!
The thing is a lot of fun to ride...it is smoother than you might expect and gins
up its RPM's smoothly and guickly...enjoy!
 

·
Registered
Joined
·
2 Posts
Ultima Cylinder Head Gasket

I am looking for a dealer that sells Engine gasket (head and base) for Ultima 127 C.L. (El Bruto). Can anyone help me with a dealer? I called Midwest allready and I can only buy it at a dealer. Called demoncycles, they don't have it in stock. Anyone who knows where I van buy it.

Thanks
 

·
Registered
Joined
·
397 Posts
well had bought a 95 softtail, it came with 113 ultima,it had a thousand miles on it, i was told to put 2500 miles on before riding it hard, so i did, i was riding in town at 35 miles an hour, then all hell broke out, took it back to the shop i bought it from, he thought my primary shoe come lose, it did make alot of noise, but i still rode it to his shop,10 miles away, to his front door, long story short, my crank snap in half, they never heard of that to happen, so rebuild the motor, got it back on the road 50 miles later, i hear a grinding noise in the top end, ride it to the shop agin 10 miles or more, a lifter went bad on me, i have been told ultima was having a problem with the lifters, so we put a new cam & lifters in. my luck has not been good with this motor, now rocker boxes are leaking, the motor seems to make alot of noise, after what i have been threw, i worrie about break down. i guess i can say its a tough motor riding it with broke crank
I am interested in buying one and other forums talk about the lifters having problems....I am still researching the pros and cons on the 107 El Bruto
 
1 - 20 of 43 Posts
Top