V-Twin Forum banner

Sudden Loss of Electrical Power

1619 Views 4 Replies 4 Participants Last post by  Von Zipper
Good Day All,
I have a 2005 FXDWGFI 40,000 miles.
I ride pretty much every day not far 10-25 miles but consistently.
Went out the other day and rapped up the throttle on a couple of gears and hit a little to high RPM popping etc.
Didn't have any issues continued riding made a few stops and starts all good.
Headed up the hill from a stop and as I was going into third the bike just quit. I looked down an d there was a total loss of electrical power. Nothing, no lights, horn etc. not even dim.
I removed the battery terminals cleaned and reinstalled, and power was restored to the lights, and ignition switch but the the speedometer lighting and mileage/code area were blank, and the turn signals do not work, although illuminated.
Starter will not engage and I cannot get any codes as that area of the speedometer does not work as mentioned.
I have checked and cleaned all the CB connections on outward facing side of the CB and the grounds.
Any ideas?
I got a new battery as the previous one was 3 yrs old but it worked well until that day.
I always hook the battery up to a tender, but NAPA said it load tested at 7 amps (should be 18) No matter I have new battery and the condition persists.
Is there a security code/Key FOB thing I need to do?
Help Please!
  • Wow
Reactions: 1
1 - 5 of 5 Posts
Power to some areas and not others leads me to think you may have blown a fuse somewhere. Battery connections that work loose can sometimes cause a voltage spike that could pop a fuse. May not be the case but worth a look. Some fuses can also appear intact visually and still be failed. A test light is handy to test them. (Just contact both exposed pins on top of each fuse with a test light that is hooked up to a good ground.) The test light should light when touching each pin with the ignition on. The battery connections on my 07 have vibrated loose on a couple occasions. Cheers!
  • Like
Reactions: 1
Woops Miggs beat me to it.
  • Like
Reactions: 1
I had the same issue on my 02 glide last year. There is a thermal breaker under the seat. I replace it and it hasn't happened again. It's mechanical and just wore out. Not sure if your model has it, but worth a look.
  • Like
Reactions: 1
Thanks all,
The thermal breaker mentioned I assume is the 40 Amp breaker?
But I will take a good look around the CB assy. box.
But it and all other fuses have been cleaned, checked and re-installed.
It is weird that I have power to everything except the speedometer.
All the lights, indicators warning lights etc. work.
(with the exception, the turn signals illuminate but will not flash in L or R activation or EMG).
I tried getting codes but no power to the speedometer display and no power anywhere when switch is moved to ACC.
I am guessing there is a short or disconnect somewhere was hoping for some info from something similar.
Will start tracing wires and connections, any info on OHM / AMP info for individual wiring would be helpful

Will advise....
1 - 5 of 5 Posts