V-Twin Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi All,

I have almost 600 miles on my 2003 1200 Custom. I had the Screaming Eagle exhaust, air filter, and rejet done at the stealer when it was new.

My question is whether engine stumble on acceleration is normal. When doing 50 or so in 5th gear, should it cough once before it smooths out?

I was told by someone that this might be normal with the SE upgrade.

Gary
 

·
Registered
Joined
·
381 Posts
Did the dealer remove the epa plug? Also it seems that the problem may be to you lugging the motor "in 5th gear at 50 mph." I normally run my rpm's at aroung 2500 to 3000 rpm's when cruising. Does dropping a gear help?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
I may well have been lugging it. The owners manual said to shift to 2nd at 15mph, 3rd at 25, 4th at 35, and 5th at 45. I called the dealer service this afternoon, they said that I should be shifting to 5th at 50 or 55 and downshifting to accelerate.

This is my first road bike, and without a tach it will take me a while to figure out the rpms.

I still wonder if they put the best jet in the carb. I will need to have it checked at my 1000 mile check. The exhaust is pretty blued where it exits the engine. Not enough to color the heat shields.
 

·
Registered
Joined
·
381 Posts
Gary, I haven't seen a stock pair of Sporty pipes that were not blued with-in the first 1000 miles. Better to be a little richer than anywhere near lean. Keep the rpm's up.
 
1 - 6 of 6 Posts
Top