V-Twin Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
39 Posts
Discussion Starter #1
Greased my steering head on my 05 Ultra for the first time..Put about 10 squeezes in without seeing any evidence..No grease coming out from either top of steering head or bottom..How much should I put in?
 

·
Premium Member
Joined
·
3,624 Posts
Keep on pumpin' till it comes out the top and the bottom. The first time usually takes nearly a whole tube of grease.
 

·
Premium Member
Joined
·
39 Posts
Discussion Starter #4
rodriguc said:
Dido...keep on pumping!!!
okay thx..........I hope general purpose automotive grease is okay cause that's what it's gettin...
 

·
Registered
Joined
·
194 Posts
I wouldn't use general purpose grease because I made that mistake already and if it is hot out and you're on the highway it will nearly liquidify and come out onto your forks. Now I am stuck with that stuff in my steering head and I have to clean it off every couple of weeks. Next time I will use something a little thicker that's made for higher temps.
 

·
Registered
Joined
·
1,799 Posts
cfromc said:
I wouldn't use general purpose grease because I made that mistake already and if it is hot out and you're on the highway it will nearly liquidify and come out onto your forks. Now I am stuck with that stuff in my steering head and I have to clean it off every couple of weeks. Next time I will use something a little thicker that's made for higher temps.
I've noticed the same thing before. Switching to HD wheel bearing grease part number 99856-92 solves that problem.
It's recommended for wheel bearings and steering head bearings(other than '97 and later Softail and Dyna).
 
1 - 6 of 6 Posts
Top