V-Twin Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a HD Sportster XLH 1989 1200cc, and have been plagued with a charging problem. I'd charge the battery up to 100%, and go out for a ride. After 100 Miles, I'd shut the bike down, and when I'd try and start it back up, it wouldn't turn over. The battery was dead. I don't have ANY extra accessories, just the standards lights to make it street legal.

My first discovery of the problem was the stater, one of the magnets was cracked off the rotor. I have replaced the stater and rotor completely. Next, we discovered that the Voltage regulator was bad. I have since replace that and just added a new battery. I've charged the puppy up, and am ready to put it back together and take it for a spin.

I wanted to know if there was anything that I am missing, or if anyone else has run into a charging problem like this before I put her back together.
 

·
Registered
Joined
·
127 Posts
I had a dead battery (shorted out) and was narrowing down options on the phone with a shop (I was on a long trip) and he said that a common problem on Sportsters are broken or loose connection where the positive cable goes into the starter. Anyway, you may want to check that.
 

·
Registered
Joined
·
381 Posts
Sounds like you hit all the right things. Put it back together, put a VOM on it to check for proper charging and make sure all the connections are tight. Let us know whats happening. Put a pic of your bike up on the sticky for us to see.
 
1 - 3 of 3 Posts
Top