V-Twin Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
I have a 2000 dusce and the speedo just quit.I checked the pickup sensor and it looked fine.I have power to the speedo head .when i turn on the key the speedo needel moves up a 1/8 in.then back down also my bike will start in the accesory position is that right? please help
 

·
Registered
Joined
·
1,177 Posts
benleee53 said:
.... also my bike will start in the accesory position is that right? please help

The Service Manual for my 2005 FXD states that the ignition circuits are OFF when the switch is in the accessory position. Perhaps someone has modified the switch (e.g. turn off daylight headlamps)? The purpose of "accessory" is to keep the ignition circuits off so you might want to check this out. Not sure how (or if) this has anything to do with your speedometer problem.
 

·
Registered
Joined
·
37 Posts
bike will start in the accesory position is that right? please help



No i don't think that's normal. I have a 2000 Deuce (carb model) & it will not start in the acc. position of the ignition switch.

You may need to disassemble the ign. switch & clean it out, check the contacts too.:hmmm:


While riding the bike, does your self cancel feature of the turn signals work properly or do you have to cancel them manually?

The bike relies on the vehicle speed sensor for a distance measurement so your signals stay on for a certain length of time, then cancel automatically.
If that sensor is bad or covered with metal fuzz on the inside of the trans., it will not supply that info & the turn signals will blink until you cancel them.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
yes thats right the turn singels stay on and i need to cancel them manualy every time.I checked the speedo sensor and it did have some small metal fragments which i wiped off and i also noticed that the trans had water inside it also and i mean a lot of water.I had just riden the bike 800 miles before i checked this .thank god it did'nt hurt the trans.:thumbsup: thanks for the help .I think the sensor must be the problem.oh bty my is also a carb dusce.
 

·
Registered
Joined
·
15 Posts
If your bike's speedo stops registering speed and your odometer does not move as far as registering miles traveled, you also realize that your directional signals do not self cancel, your problem is more than likely the VSS (vehicle speed sensor) on the transmission. It collects metal particles that are from the wear in the transmission being that it is a magnetic pickup that reads off the 4 th gear cog in the transmission. You can clean it off then replace it, but most times it will go bad again real soon. The best thing to do is replace it. I believe the cost is around $50. A simple repair requiring one bolt for removal which you have done already. It's located on the transmission just behind the rear pipe. A good quality gear lube will all but eliminate this problem.
 
1 - 6 of 6 Posts
Top