V-Twin Forum banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
360 Posts
Discussion Starter #1

My 04 Fatboy develops condensation in the speedo and is leaving a pretty good film on the glass. I've had it out of the bike and didn't see a way to open and clean it. Any tips?

Tom
 

·
Registered
Joined
·
87 Posts
TomD said:
My 04 Fatboy develops condensation in the speedo and is leaving a pretty good film on the glass. I've had it out of the bike and didn't see a way to open and clean it. Any tips?

Tom
I had the same issue, and suspect it was from drying with the airforce blaster. the spedo is a sealed unit but its not water tight, it only has a gasket around the edge where it mounts under the console. It can handle rain and washings but did not like the dryer pushing water around it. so you either live with it or you will have to have the dealer replace it to certify the milage.


CREAMIN 1
______________________________________
2006 FLSTFSE² Screamin’ Eagle® Fat Boy®
SE Race Tuner
SE 8mm Spark Plug Wires :D :dry:
SE Stage I Air Cleaner w/ K&N Filter
V&H Big Shots Staggered
Kuryakyn Mark IV Cruise Arms
Boss #36S1 saddlebags
Corbin gunfighter w/wildfire Stitch, red flames & backrest
________________________________________





HOME PAGE
 

·
Premium Member
Joined
·
360 Posts
Discussion Starter #5
Thanks guys, for a while there I thought I was special. Just another something that should have been worked out on a supposed high end bike.

Tom
 

·
Registered
Joined
·
228 Posts
The condensation sucks. I had a Low Rider for 3 1/2 years with no problem. I get the Deluxe and from day one the speedo starts fogging up on cool sunny days.
 

·
Registered
Joined
·
63 Posts
I had the same problem on my 2006FXSTBi I was lucky they changed it for me. I understand its a common problem makes you think Mo Co would have it sorted by now maybe they have but i dont think so...............
 

·
Registered
Joined
·
1,799 Posts
Can't say I've experienced that on either of my RK's and they get wet all the time. I have heard many say they have had this problem though.
 

·
Registered
Joined
·
9 Posts
Stealer told me "yep, 'most all HD's do that. Motor Company says its normal since it isn't a sealed unit". However, another stealer said that the Company considers it normal as long as the moisture clears out within 24 hours on a relatively warm, sunny day. Might pay to ask another service dept, if available to you. Pushing water into it with a Blaster or compressed air would tend to compound the problem...
 
1 - 9 of 9 Posts
Top