V-Twin Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,100 Posts
Discussion Starter #1
My left muffler has come off again for the second time in about 23,000 miles. Last time it happened I chalked it up to being a streched out torca clamp so I replaced both along with the two hanger bushings.

Why do you suppose that could happen? I was thinking of useing a tailpipe expander on the pipe that the muffler connects to in order to maybe get a better fit?

This ever happen to any of you, and how did you fix it? Mufflers are the old slash cut one piece screaming eagle mufflers part # 64910-99 on a 2001 E-Glide. I'd like to keep them if possible, they're not too loud and I hink they flow well?
 

·
Premium Member
Joined
·
4,701 Posts
Mine was doing that for a while too so I also replaced the clamp. Whenever henever I take off parts of the exhaust I put my expander to them to make sure they are round and the right size. However, I don't remember if I did that to get my slip-on to stay on but it certainly won't hurt to try. I'd do it on both ends.

Are you using a torque wrench set at 60 lbs. on the clamp?
 

·
Registered
Joined
·
1,176 Posts
Had the same issue a while back. Used the expander to true up the end of the pipe, but it still didn't help. I finally got it to stay by adding a shim cut out of a beer can between the clamp and the pipe.
 

·
"Jane you ignorant slut!"
Joined
·
2,292 Posts
Make sure the clamp is aligned with the end of the pipe. It also does not hurt to use high temp sealer when putting the pipes together. Bub has this in thier instructions.
 
1 - 4 of 4 Posts
Top