V-Twin Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Downloaded and installed the new Screaming Eagle software. During the install an error comes up saying the drivers aren’t installed. I tried anyway and connected to the bike. Computer does see it in devices, but the software doesn’t because of the missing driver.
Removed and downloaded a number of times with the same results.
Any idea where to get the driver or how to fix it? And yes I have tried the repair button
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
That’s where I downloaded the software from. It almost seems corrupt. And the ”tech support” is call your local dealer
 

·
Make me use my bullet?
Joined
·
13,180 Posts
Where did you get the SEPST? Can't they help?

What version of Windows do you have? Is the tuner compatible?

Is it a new tuner or has it been married to another bike?

There are a whole lot of issues that could be in play. This is not a Milwaukee Eight Engine problem, this is a computer problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I totally agree, a computer or software issue.
I was able to borrow another PC from someone and tried it. Bingo! It all works and was able to use the tuner with no issues. Why the oPC didn’t want to load the SE tuner drivers I will never know.

Where did you get the SEPST? Can't they help?

What version of Windows do you have? Is the tuner compatible?

Is it a new tuner or has it been married to another bike?

There are a whole lot of issues that could be in play. This is not a Milwaukee Eight Engine problem, this is a computer problem.
 

·
Super Moderator
Joined
·
21,087 Posts
I totally agree, a computer or software issue.
I was able to borrow another PC from someone and tried it. Bingo! It all works and was able to use the tuner with no issues. Why the oPC didn’t want to load the SE tuner drivers I will never know.
What sort of permissions were you logged on with? And did you try it with the antivirus turned off?
 

·
Registered
Joined
·
5 Posts
Downloaded and installed the new Screaming Eagle software. During the install an error comes up saying the drivers aren’t installed. I tried anyway and connected to the bike. Computer does see it in devices, but the software doesn’t because of the missing driver.
Removed and downloaded a number of times with the same results.
Any idea where to get the driver or how to fix it? And yes I have tried the repair button
Get a thundermax! More monety but muchhh better product. Heard it a number of times, guy go thru tuners an end up getting a thundermax an are HAPPY,, i got one an no problems for a ss124
 
1 - 7 of 7 Posts
Top