V-Twin Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
268 Posts
Discussion Starter · #1 ·
Im thinking about buying a used Screamin Eagle air cleaner kit. The guy says it only had 100 miles on it before he took it off when he sold the bike. From reading this forum I understand there are two different versions of this. The original style, and the revised one to correct the oil dripping problem. How do I tell which version this is? Are they different part numbers?
 

·
Registered
Joined
·
6,413 Posts
The original SE kit has a chrome piece with a banjo type fitting on each end. One end (the rear) also has a nipple for a 3/8' hose. The chrome piece is rounded sorta like a quarter moon, if that makes sense. They are probably the same part # but new one has an A or B behind it. Don't have a P&A available to check. New version also has 2 small diameter (about 1/4") rubber hoses that connect to 2 separate banjo fittings (also know as breather bushings).
 

·
Premium Member
Joined
·
71 Posts
SE Air cleaner

Duece,
I had one of the "after the chrome cross-piece" SE air cleaners. Did not help the drip.
The latest air cleaner backing plate (if I can remember the picture I once saw of it correctly) still has 2 rubber hoses coming into the backing plate, but they enter it higher up than the one I had. Because the hoses do not enter that close to the carb intake, I have my doubts about it stopping the dripping, though it may lessen it.
I use a Ness Big Sucker II, and it stopped the drip. However, I'm hearing that the quality of the Ness units has taken a dive, so can't recommend em until I know more about whether this is true or not.
The Ness backing plate allows the head vents to exit near the carb intake (note I said carb. I know nothing about FI and the Ness units) so the vented vapors can get sucked into the engine and burned - unless the vents are near the intakes, this cannot happen.
Good rides,
RainRider
 

·
Registered
Joined
·
1,496 Posts
The new S/E is like the Ness setup.
Oil drip from a TC A/C is usaly a oil pump alinment problem. I run my Dyna to 110 MPH and curse at 80 and have no oil drip problem, of course I alined the oil pump myself and I dont no why the factory dont get them right.
 
1 - 6 of 6 Posts
Top