V-Twin Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
You hear people here and elsewhere stating "Get the Stage 1 Download 'just in case' the DFO breaks down..."

Has anyone's EVER broke down? I assume not, and I'm swaying towards just getting this instead of getting the Stealer's download...

Thanks!
 

·
Administrator
Joined
·
11,242 Posts
Everything depends on what you want out of the bike. Here is somthing to consider.... The download increases your rev limit to 6200 from 5700, the DFO doesn't.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #3
I ride the speed limit generally - no faster. I never crank it...maybe on an open road I'll twist the throttle when I'm already going 70 - 80 klms/hr...but other than that, I'm not one of those guys you see ripping off the starting line...does this make a difference then? Would I be 'safe' ignoring the rpm increase? Thanks.
 

·
Registered
Joined
·
2,765 Posts
I have the stage 1 download and run a DFO on top of it. I do this due to I have true duals and it was still on the lean side.
When I first installed my DFO it was no good. I sent it back to Dobeck Peformance and they replaced it with no problems what so ever.
I do like the fact that if it ever goes bad I do have the download so as not to burn up the motor on a trip. The increased rev limit is a nice bonus.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #5
The pipes I'm getting are true dual Hard Krome 3" (1 3/4 pipe inside surrounded by 3" 360 degree heat shields)...they have baffles though, so do you anticipate me having the same problem as you (lean)? Thanks!
 

·
Registered
Joined
·
2,765 Posts
DRIMNER1 said:
The pipes I'm getting are true dual Hard Krome 3" (1 3/4 pipe inside surrounded by 3" 360 degree heat shields)...they have baffles though, so do you anticipate me having the same problem as you (lean)? Thanks!
When I installed my duals I had a bad popping on decell. Also my bike was running pretty hot. Installed the DFO and adjusted it as per instuctions. Bike runs great now with no popping at all. Runs much cooler too. I have never seen it over 250* even on the hottest So Cal days. Most of the time it runs about 210*. A check of the plugs after a long high speed run and they look perfect.
Im not a hot rodder so as long as my bike runs like it does Im happy.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #7
I can't decide whether to:

get stage 1, get pipes, do big sucker kit, and a new air cleaner cover to boot

OR

get pipes, do nothing else except maybe add a new air cleaner cover

OR

get pipes, DFO, and maybe a new air cleaner cover

OR

get stage 1, get pipes, get DFO, etc as in the first example...

All comes down to money, but I'll spend it if and where i need to...
 

·
Premium Member
Joined
·
3,624 Posts
04GLIDE said:
I have the stage 1 download and run a DFO on top of it. I do this due to I have true duals and it was still on the lean side.
Kinda me, too....My bike ran good with the Stage 1 and Duals. It wasn't getting hot and the plugs looked good. However, I added a DFO and found out it ran better.
 

·
Premium Member
Joined
·
3,624 Posts
DRIMNER1 said:
I can't decide whether to:

get stage 1, get pipes, do big sucker kit, and a new air cleaner cover to boot

OR

get pipes, do nothing else except maybe add a new air cleaner cover

OR

get pipes, DFO, and maybe a new air cleaner cover

OR

get stage 1, get pipes, get DFO, etc as in the first example...


All comes down to money, but I'll spend it if and where i need to...
Since you aren't into turning your motor at redline, I'd get the Big Sucker, DFO, and pipes. Two people that I work with have done just that on their '05 bikes are are very satisfied.
 

·
Registered
Joined
·
903 Posts
I've had my DFO for almost three years and I've never had a problem with it. I have the Big Sucker and some V&H Oval slip-on mufflers. I still get an occasional pop every once in a while out of it on decel and I can't seem to get rid of it so I've learned to live with it. I'm thinking the stage 1 ECM flash might help.
 

·
Registered
Joined
·
2,765 Posts
Well get this I went for a ride tonight and all of a sudden my bike starts running like crap. Threw codes twice and stalled twice at stop lights. Im thinking WTF is going on. It would run good for a few miles and then run like crap for a few miles. I got it home and started looking around and with it running moved the wires going from the DFO to the injectors and it started running good again. I guess I have a bad connection somewhere. I will have to let it cool down before I check it out real good. I allready have a blistered knuckle. I pulled the codes and they were for rear injector open/low.
This is kinda strange after posting in this thread about DFOs.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #12
Boy its pissing rain and 5 degrees here in Canada, must be nice to be out...I havent stored it yet though, so hoping for a few more rides...

I re-read the whole thread, and you mention having done the stage one first then getting the dfo...so when you say 'running like crap', should i interpret that the stage one (backup for just this such ocassion) did not pull its weight for your setup?

I mean this with all sincerity, as I'm just going it over and over again lately whether or not i 'need' the stage one as a 'backup'...

I am leaning towards no stage one, and just the dfo..

Good luck with your prob, I'm sure its something brutally simple....
 

·
Registered
Joined
·
2,765 Posts
DRIMNER1 said:
Boy its pissing rain and 5 degrees here in Canada, must be nice to be out...I havent stored it yet though, so hoping for a few more rides...

I re-read the whole thread, and you mention having done the stage one first then getting the dfo...so when you say 'running like crap', should i interpret that the stage one (backup for just this such ocassion) did not pull its weight for your setup?

I mean this with all sincerity, as I'm just going it over and over again lately whether or not i 'need' the stage one as a 'backup'...

I am leaning towards no stage one, and just the dfo..

Good luck with your prob, I'm sure its something brutally simple....
I should be more clear on how it runs with just the stage 1. I can tell you exactly because I had to disconect my DFO Just 1/2 hour ago due to a broken wire. I went for a ride afterwards. Bike runs OK but pops on decel and doesn't have the crisp throttle response it had with the DFO. I know that it will run a little hotter also as it did before. I will give it to a buddy of mine and have him check it out and find out where the break is in the wire.
Thats the good thing about having the stage 1 I can still ride it.
When I was talking about the bike running like crap in the other post that was with a broken wire on the DFO. With a broken wire the rear injector was not working at all times.
 

·
Premium Member
Joined
·
59 Posts
I agree with 04Glide. I put Arlen Ness Big Sucker, RevTech DFO and Rienhart True Duals on my RK. Runs great, but I plan on getting the download next time I take it for service. Note that after the download RevTech recommends the switches in the DFO be changed.

Ride Safe

JJL
 

·
Registered
Joined
·
903 Posts
What's the stealer charging these days for the stage I flash?
 

·
Registered
Joined
·
903 Posts
Thanks for the quick reply. Now I have to decide if I should add that to my DFO or not.
 

·
Premium Member
Joined
·
3,624 Posts
HarleyJoel said:
Thanks for the quick reply. Now I have to decide if I should add that to my DFO or not.
IMO, not if you don't want to raise your rev limiter. The worry about the DFO breaking down is a lot of unneeded paranoia. Very few fail. It it did, you likely wouldn't cook a motor that had only exhaust and air cleaner changes.
 

·
Registered
Joined
·
113 Posts
Don't know if this adds anything to the discussion, but I have the Stage 1 download at the 1000 mile check. Then about 1.5 years later, I added the DFO. Before the DFO, the bike ran like #*&%# at low speeds and had decel popping. After the DFO it ran much better (but still not perfect) and the decel popping was gone. Have had the DFO for only about 3 months, but no reliability problems.

I wondered if I should have bought the PCIII or maybe SERT. It still runs a little rough at low speeds (25 -35) and would like to know it the PCIII could correct this. I believe that this is due to a lean EFI map.
 

·
Registered
Joined
·
903 Posts
I'm just going to save my money (and spend it on other "toys") rather than do the download then. It took a while of adjusting but I finally have it where it doesn't backfire at all and rarely decel pops.
 
1 - 20 of 21 Posts
Top