V-Twin Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just recently bought a chopper it has a revtech 110 motor went to start it today and it only turned over like once with a compression sound and the battery light came on the Instrument panel. I tested the battery it read 12.26 so I charged the battery and hooked it back up same thing. Bike ha sa been setting up for a little over 3 months any advice?
 

·
Registered
Joined
·
8,350 Posts
load test the battery , 12.26 is nearly dead,,, minimum is 12.6,, max 13.2... it should drop no lower than 9m6 volts 7nder load..check the starter draw.. it should be in the 160-190 amp draw range... with a fully charged battery..

cross the green wire at the selenoid to the + battery cable,,, with it in neutral,,, if it turns over,,, there is an issue in the primary starting circuit..

if you dont have the equipment to do these tests,,,,, guessing i's like sitting back and throwing money (parts) at the bike hoping the next one (part), will cure it...

good luck...
 

·
Registered
Joined
·
1,370 Posts
That voltage would say your battery was at about 60% of charge. If the battery was stored for some time like that it can effect cranking amps. Also check for compression releases not sure if those motors had them
 

·
Registered
Joined
·
2,941 Posts
load test the battery , 12.26 is nearly dead,,, minimum is 12.6,, max 13.2... it should drop no lower than 9m6 volts 7nder load..check the starter draw.. it should be in the 160-190 amp draw range... with a fully charged battery..

cross the green wire at the selenoid to the + battery cable,,, with it in neutral,,, if it turns over,,, there is an issue in the primary starting circuit..

if you dont have the equipment to do these tests,,,,, guessing i's like sitting back and throwing money (parts) at the bike hoping the next one (part), will cure it...

good luck...
Now that is a text book answer follow it.
 
1 - 5 of 5 Posts
Top