V-Twin Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi...my name is Jack and I live in Austin Texas. I have a 2001 Ultra Classic with big bore,stage 2,excessive chrome (my wife says),progressive front springs,stc. etc..I have a very strange problem with my radio that one of you might be able to help me with:After riding in the heat for sveral hours, the volume control ceases to function. After I have turned the bike off and then restarted, the volume control will only turn the volume down and not up!! I have jiggled all the switches and still nothing happens. After the bike has rested overnite, the volume seems to work fine. It seems to be related to the heat, but I don't know .Last time I took it to austin harley it wouldn't repeat the problem (of course);
Any one out there have any ideas??
Thanks...Jack
 

·
Registered
Joined
·
2,300 Posts
When it happens, if you change the function of the volume control to something else, does it respond?

This would give you a minimal indication on wether it might be switch or radio related.
These things are real difficult to diagnose without following the flow charts in the manual.
 

·
Registered
Joined
·
240 Posts
Troubleshooting 101. If you can Isolate to the switch it can easily be replaced (I did it myself on my FLHT) Harley provides a kit to replace the switch. ($20 or 30 bucks)A thermal problem could be tough to reproduce. You could try a hair dryer on the left handlebar control, being careful not to melt anything to reproduce the problem. If this doesn't work, I would check the radio connections under the fairing.

Let us know what you find. I hope this helps

Fastlane
 

·
Registered
Joined
·
2,300 Posts
Yup, the switches are easy to replace, it's just that with this sort of symphtoms a solid state component is more suspect.
The other idea is to call Radio Sound in KY, as they often are much more helpful then the dealers and have a lot of data as they make the radios.
 

·
Registered
Joined
·
240 Posts
I'm guessing the rig is out of warranty as well. I called radio sound myself and you are correct Hippo. They have excellent customer service
 

·
Registered
Joined
·
22 Posts
Radio Sound in KY, eh?

Anyone care to share the phone number for them?

I have some questions to ask them about the radio in my Road Glide.

THANKS!
 

·
Registered
Joined
·
5 Posts
I've had the same problem ... Every time the problem turned out to be a stuck switch ...

Found this out by going into diagostic mode , as you press each switch on the radio and handle bar controls, the display indicates which switch has been pressed ... This is a good way to test all your controls before you have a problem, gives you an idea of the way the switches work ....

If you have a problem and one is hung up, the display will indicate this by flashing a 1 in the bit position of the stuck switch ... If any switch is stuck all switches and controls quit working .. even the power ...

On mine, it has always been one of the station buttons hanging up in the hot weather ... Probably because these are the switches I most often press ..

Once you realize whats happening you can play around with the stuck switch and it will pop back out .. Or as it cools down the switch will pop back out on it's own ... Hope this helps ...
 
1 - 8 of 8 Posts
Top