V-Twin Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
HIPPO;

I was wondering if you could tell me what changes, if any, were made to the FI for the 2002 model year. Is the FI for the Electra Glide series used in any other bikes and have others complained about this type of problem or is this type of problem unique to the Electra Glide Classic?

Thank you
Richard H-D
 

·
Registered
Joined
·
2,300 Posts
The 01 EFI baggers were Marelli bikes, the 02's are Delphi's. Completely different system.

The EFI softails have had the Delphi system for a couple of years, but they have completely different pipes. If you consider the Delphi is heavily MAP based, small changes in pipes make big differences.
The Delphi software on the 02's is also different from what was used previously.

Generally speaking the Delphi system is a much better system, stock against stock, it's just it's nature that it can get caught behing the eight ball now and then, and it really is minimal.
As modern EFI systems go, compared to some other bikes, you could pretty much call the drivability flawless, but it will never pull out of the hole like a well tuned carbureted bike.

I have heard mentions of some updated stock flashes. If you find the guy at your dealer that knows of these things and you get on his good side, he might be able to find if there is one for your bike or not.
 

·
Registered
Joined
·
2,300 Posts
All the instances I have seen of people mentioning this have been touring bikes, but that doesn't mean much as better then 95% of the bikes I deal with or people I ride with are / have baggers.
There were a couple of guys even on this board that visited me briefly while picking up their bikes, and they mentioned and /or had problems with the same thing. They also later mentioned that by the time the bikes had a little over 1000 miles the problems for all practical purposes were gone, no actions on anyone's part.
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #4 ·
HIPPO;

Thanks for your replies.

Called my local H-D dealer and set up my 1000 mile service for July 26th. Tech says he has heard of this problem before but no cure came to mind. Says they can check out a few things but not much can be done with the FI and that H-D bikes have a mind of there own...

He did tell me that other than the first 50 miles, he doesn't agree with the H-D break-in period... he feels that the bike should be ridden a little harder but not abused, of course. He feels that anything under 2000 rpm is lugging the motor. 55 mph in fifth gear is only 2500 rpm...

Your thoughts?

Richard
 

·
Registered
Joined
·
2,300 Posts
Anything under 2500 is lugging the engine. They love to be beat on a little, that's what I meant originally.

Personally I don't worry about break in at all and haven't had a problem yet. Broke the RatGlide in on a 90 mph run thru the desert to Vegas and she seems to be happy. (or at least doesn't dare to speak or act up, LOL)
 
1 - 5 of 5 Posts
Top