V-Twin Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Greetings to all,
This is the 1st time I'm actually posting a technical question so bear with me. I have a 2003 Ultra Classic. I installed new chrome switch housings over the winter with a friend. I removed the old black housings no problem. When we got to installing the new housings, it was a pain in the A$$ to cram all the wiring back into the housings. We referred to the manual several times and finally got it buttoned up. NOW, here's the kicker...When I have a CD playing and try to switch to AM/FM, CB, or weather band, the button that is SUPPOSED to do this only changes the TRAcK on the CD. It does nothing else. I then checked the rest of the buttons, which appear to work properly. When I went to the clutch side to check everything out, it seems that the PTT button now works the treble, bass, and DOWN volume control! EEK! (I feel like I'm in an episode of the three stooges...) Everything else seems to be working properly. I removed the clutch-side switch housing to have a look and it looks like some of the black electrical wrap was pinched inside the perch. I can see a strand of what looks like a frayed wire from where the electrical wiring wrap was smushed. Could THAT one strand of stray wire be the cause? Possibly a short somewhere when I mashed all the wires back into the housing? And if someone here knows the fix, would it be something a dealer should handle? PLEASE HELLLLP!!!:crying:
 

·
Registered
Joined
·
4,820 Posts
wiring diagram

I'd vote for you getting a manual and having the wiring diagram. What your describing appears to be a crossed wire (wire a where wire b should be.) It will be almost impossible to check that without a diagram.
 

·
Registered
Joined
·
1,456 Posts
When I installed my chrome switches on my FLHTCI I pinched a wire upon re-assembly. The electrical system went nutz until I took it apart, found the pinch and taped it up. Take it back apart and check for smashed wires that got caught between the housings.
 

·
Administrator
Joined
·
11,287 Posts
KrustyHog said:
Greetings to all,
This is the 1st time I'm actually posting a technical question so bear with me. I have a 2003 Ultra Classic. I installed new chrome switch housings over the winter with a friend. I removed the old black housings no problem. When we got to installing the new housings, it was a pain in the A$$ to cram all the wiring back into the housings. We referred to the manual several times and finally got it buttoned up. NOW, here's the kicker...When I have a CD playing and try to switch to AM/FM, CB, or weather band, the button that is SUPPOSED to do this only changes the TRAcK on the CD. It does nothing else. I then checked the rest of the buttons, which appear to work properly. When I went to the clutch side to check everything out, it seems that the PTT button now works the treble, bass, and DOWN volume control! EEK! (I feel like I'm in an episode of the three stooges...) Everything else seems to be working properly. I removed the clutch-side switch housing to have a look and it looks like some of the black electrical wrap was pinched inside the perch. I can see a strand of what looks like a frayed wire from where the electrical wiring wrap was smushed. Could THAT one strand of stray wire be the cause? Possibly a short somewhere when I mashed all the wires back into the housing? And if someone here knows the fix, would it be something a dealer should handle? PLEASE HELLLLP!!!:crying:
In answer to your question, yes that could easily cause it.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
Thanks!!!

Thanks to all who posted! I appreciate the help. I believe I have it narrowed down to the pinched wire. And yes, the wiring diagram helped! Looks like it was still making the connection when it was pinched, but when I moved it out of there and tried to stuff it back into the housing (while looking over my shoulder and whistling innocently) it severed the connection, causing it to go haywire. I will post the results as soon as she's happy again!

Thanks!

:cheers:
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #6 ·
All better!

Got the control housings apart last night. Found the ONLY wire (thank GAWD) that was cut in two from pinching the harness on the clutch side. Broke out the ol' soldering gun and fixed'er right up! Only took about 1/2 hour. Thanks again for all your help fellas!
 
1 - 6 of 6 Posts
Top