V-Twin Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
751 Posts
Discussion Starter · #1 ·
Has anybody run into a muffler that just will not seal? I'm putting on a set of Krome Werks mufflers on my 05 Eglide and have tried 2 different new clamps and I can't get the right muffler to seal completely. I've tried moving the clamp forward and then back, slid the muffler on a little further, no good.Does anyone have any ideas?

Thanks,
Rick
 

·
Premium Member
Joined
·
1,159 Posts
The Torca clamps stretch with use, and need to be replaced after a few uses. HD says replace them every time. I've gone 4-5 times before they quit working. I've also had your problem with mufflers and made a shim out of a strip of beer can.
 

·
Premium Member
Joined
·
356 Posts
I had the same problem with my V&H oval slip ons. I just used some high temp silicone (gasket maker) and took care of the problem. Just let it cure the recommended 24 hours.
 

·
FOG
Joined
·
6,970 Posts
GrayRider said:
Why not just buy a new clamp? Why jerryrig the thing with silicone and beer can shims?
".......and have tried 2 different new clamps and I can't get the right muffler to seal completely."

T113
 

·
Premium Member
Joined
·
356 Posts
well, sometimes it just will not seal. I tried the new clamps sent with the mufflers and the old clamps off the original header. For 5 bucks I took care of the problem. That is why they make form a gasket. For those stubborn leaks.
 

·
FOG
Joined
·
6,970 Posts
GrayRider said:
Sorry, somehow I missed that. Back to the silicone and shim them.
That's okay, Gray....I miss at least half of what goes on around me on some days. Must be the water here in Sun City. :D

T113
 

·
Registered
Joined
·
751 Posts
Discussion Starter · #13 ·
GrayRider said:
Why not just buy a new clamp? Why jerryrig the thing with silicone and beer can shims?

As I stated in the original post I had tried 2 new clamps. Didn't work.

Rick
 

·
Registered
Joined
·
751 Posts
Discussion Starter · #14 ·
Thanks for all the tips. I used some thin shim material between the exhaust and the muffler along with some hi-temp silicone and it seems to have done the job.

Thanks again,
Rick
 

·
Premium Member
Joined
·
101 Posts
Eglider05, I'm having same problem with my left muffler wont seal I have cycle shack slip/ons did your fix hold up?
 

·
Registered
Joined
·
751 Posts
Discussion Starter · #16 ·
Deluxe said:
Eglider05, I'm having same problem with my left muffler wont seal I have cycle shack slip/ons did your fix hold up?

So far so good. If it's leaking I can't tell. Before the fix there was absolutely no doubt.

Rick
 
1 - 16 of 16 Posts
Top