V-Twin Forum banner
1 - 4 of 4 Posts

· Premium Member
Joined
·
90 Posts
Discussion Starter · #1 ·
Not sure if this is the right forum but what would be the symptoms of a bad/weak compensator. I am now running a 103 and there is a vibration at around 2200RPM that feels mechanical. By mechanical I mean you have your normal vibration but there is a feeling that there is also a definite hit with the vibration. If I had a non B motor, I would think my motor mounts were bad and the motor was hitting metal to metal. The dealer has been over the motor 100% and I even got the stroker crank out of it because my runout was 0.004. All bearings were also replaced during the rebuild. The dealer has also tore the primary apart and inspected everything but found nothing.

While the motor was at 95ci I was getting about 38mpg with an average speed of 62mph. Not great but the dealer replaced the pistons with over sized pistons, due to piston slap, and since then I can not get better than 30mpg. The dealer has since replaced the crank putting the engine at 103ci and the mpg is still setting at 30. And yes, I have tried being very careful with the throttle trying to get every bit of distance out of a gallon of gas as I could. However, when the bike was still a 95ci, if I kept the bike under 50MPH and lug the engine I can get 44mpg.


If it was just the vibration, I would not be so concerned but since it feels like something is hitting something else and my MPG is so low I am a little concerned.

And yes, I am now at the point of grasping at straws.
 

· Registered
Joined
·
4,706 Posts
Not sure if this is the right forum but what would be the symptoms of a bad/weak compensator. I am now running a 103 and there is a vibration at around 2200RPM that feels mechanical. By mechanical I mean you have your normal vibration but there is a feeling that there is also a definite hit with the vibration. If I had a non B motor, I would think my motor mounts were bad and the motor was hitting metal to metal. The dealer has been over the motor 100% and I even got the stroker crank out of it because my runout was 0.004. All bearings were also replaced during the rebuild. The dealer has also tore the primary apart and inspected everything but found nothing.

While the motor was at 95ci I was getting about 38mpg with an average speed of 62mph. Not great but the dealer replaced the pistons with over sized pistons, due to piston slap, and since then I can not get better than 30mpg. The dealer has since replaced the crank putting the engine at 103ci and the mpg is still setting at 30. And yes, I have tried being very careful with the throttle trying to get every bit of distance out of a gallon of gas as I could. However, when the bike was still a 95ci, if I kept the bike under 50MPH and lug the engine I can get 44mpg.


If it was just the vibration, I would not be so concerned but since it feels like something is hitting something else and my MPG is so low I am a little concerned.

And yes, I am now at the point of grasping at straws.
Sounds to me like a really bad tune or lack of one.
 

· Premium Member
Joined
·
90 Posts
Discussion Starter · #4 ·
Sounds to me like a really bad tune or lack of one.
I am using the DTT IID and have played around with the fuel and timing maps quite a bit. I have even defaulted back to the canned maps and letting it work its way into a tune and that does not help either condition.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top