V-Twin Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have an 02 Electra Glide Classic that just turned 40K miles. My oil pressure has always sat at 32 psi when going down the road and near 0 at a stop. Two days ago I went for a ride and the highest the oil pressure would go was about 16 psi. Oil level is fine, oil and filter were changed about 300 miles ago. Any ideas as to why oil pressure that has been consistent for 4 years would suddenly change like that?
 

·
IronButt
Joined
·
6,364 Posts
Well the first tihng I would do is check it with another gauge. Many times the diaphram in the sender will get a small leak nad allow psi to bleed down and you get less of a psi reading. OR something may have gone through the pump and damaged it?? OR the bypass spring was weak and got weaker, Many things the spring thing I have only seen once. But first thing is get a gauge or a new sender and try it. You can buy a gauge at a auto zone for about 35$ and you would then own a tool for life a sender is about the same money wise you could just try it?? Let us know what you found out.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Low Pressure Fixed

Thanks for your input. I have ordered a Baisley bipass spring. I also posted this question in another forum and a member there suggested that since the problem happened so close to the oil change that I consider changing the oil filter. I did this and my pressure immediately went back to 32 psi! Never had an oil filter fail before so I never would have thought of this on my own.:beer:
 
1 - 3 of 3 Posts
Top