V-Twin Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
i was taking my sunday ride when my 04 883c started losing power. I thought I was out of gas and sitched the petcock but to no avail. Pulled the enricher knob out and was able to make it home. Pulled the air kit and found that the gsket was bad (also found the vacuum plate for my se air kit was screwed up had to order another). does anybody think the new gsket will solve this problem or could it be something else. engine did not stall when i kept it reved up and had the enricher knob pulled out.
Thanks in advance
sam
 

·
Bugs
Joined
·
47 Posts
Donno. Sounds mostly like a shortage of fuel more than too much or too little air. I'd probably check the lines, strainer, petcock, etc. I'm assuming no bad gas, no dirty gas.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
i will have to check that out. as far as i know i didn't get dirty gas but who knows. Thanks for the tip
 

·
Bugs
Joined
·
47 Posts
I'm not your best tech source - My own Sporty is new and I haven't had any trouble with it at all. Only been in it so far to rejet and install stage 1, so consider my comments to be worth what they cost. In re your problem I wonder about the fuel vent system too. I might try removing the fuel supply hose at the carb to see if I can drain fuel with a good flow into a jar. The hose clamp on that hose is probably 1-time use only, so you might need to have a replacement on hand before trying this. Not sure it would show a vent problem unless lots was drained, but it should show blocked/not blocked fuel to the carb. In re the tank I wouldn't pull it until I thought I had a reason, myself, and if I had to I'd go straight to my HD service manual. I don't touch my bike without it open and at my side. It's totally worth the $50.
 
1 - 6 of 6 Posts
Top