V-Twin Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I have a 2001 Deuce with 17,500 miles. Noticed the other day that the return line coming out of the engine is leaking (quickly). Without a doubt, the oil is coming from the O-rings on the outside of the line and also inside the chrome nut/fitting.

I have taken the line off, and replaced the O-rings with brand new ones.... twice..and new clip. Oil is still leaking. I have also tried O-rings that are slightly larger then stock, thinking that it may seal it better....and no luck at all. I have taken the line on and off probably 8 times, with different combinations of O-rings, and NOTHING WORKS.

Advice? I need it bad. Harley techs just keep saying they have no other ideas..... How can this not work with brand new rings? I can't believe it ever worked to begin with. Seems like a horrible design. I have no clue where to go from here other then buying a new chrome fitting and line (at $40 a piece)...although I cant see how either of those two could have gotten damaged. Theres certainly no visible damage. Also, the original O-rings that came out of it are in perfect shape..no damage whatsoever. PLEASE HELP!!!
 

·
Registered
Joined
·
213 Posts
Have you took the line off, and checked it on the back side, just to make sure the line itself doesn't have any cracks or anything in it ? Just a suggestion.
 

·
Premium Member
Joined
·
5,217 Posts
If you replaced the o ring and it still leaks, you need to look elsewhere. As mentioned, look at the line itself for hair line cracks. Look at the fittings very carefully. If it were me I would replace the line and fittings.
 
1 - 4 of 4 Posts
Top