V-Twin Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I reccentally made some upgrades to my EVO. I started at Stage 1 and put a Screaming Eagle Carb on. For Stage 2 I added an Andrews EV27, Andrews EZ-Install Pushrods, HTTMT Tappets, with a S&S Metal Breather Gear.

It was running like a champ and the day before riding to Thunder Beach in Panama City Fl, I had to replace the voltage regulator, but other than that no issues. I had what I believe to be a vacum leak at the carb, I got a stretch of tubing and ran it between the two nipples that was open. That stopped the oil from coming out and the oil from flying out and covering the side of the bike. Everything was great again. Then suddenly I heard what sounded like a hammer on the front top end of the motor and my oil pressure dropped to nothing, the oil light came on and as I was getting ready to pull over it died, I tried to start it again and it did but had no pick up and sounded very rough and died again. I checked the oil resevior and it was still full. On the back part of the exhaust where it joins the front pipe there was what looks like oil.

It has fire and everything is trying to turn over but nothing. I don't want to have to tear it apart if I don't have to, but I'm at a loss with this one. Any and all helpful information would be GREATLY appreciated.

Thank you for any information.

Hammer
 

·
Super Moderator
Joined
·
3,284 Posts
Sounds like there is a good possibility the oil pump failed.I would check the keys on the pump for shearing.If they are,then something made its way into the pump and locked it up and then the keys sheared.
Either way, from what you describe I believe there is doing to be a fair amount of teardown and inspection involved to get to the root problem and the resulting damage.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Sounds like there is a good possibility the oil pump failed.I would check the keys on the pump for shearing.If they are,then something made its way into the pump and locked it up and then the keys sheared.
Either way, from what you describe I believe there is doing to be a fair amount of teardown and inspection involved to get to the root problem and the resulting damage.
Thank you Sir,

I was hoping a tear down wouldn't be involved....But it is what it is. I'd rather be safe than sorry, so here comes a tear down LOL
 

·
Registered
Joined
·
9,402 Posts
Check the adjustable push rods first,, then, go from there,,,
It does sound like the key in the oil lump drive gears jas sheared,,, no oil pressure says that,,, since the tank is full,, taking the outer cover off the pump will access the pressure side of the pump,,, if the tank is empty, the return side key sheared
Or the drive key in the drive gear,,, in the cam chest sheared stopping both sides of the pump..
..I have seen an occasional shearing of the key/ on the pinion shaft,,,
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Check the adjustable push rods first,, then, go from there,,,
It does sound like the key in the oil lump drive gears jas sheared,,, no oil pressure says that,,, since the tank is full,, taking the outer cover off the pump will access the pressure side of the pump,,, if the tank is empty, the return side key sheared
Or the drive key in the drive gear,,, in the cam chest sheared stopping both sides of the pump..
..I have seen an occasional shearing of the key/ on the pinion shaft,,,
Thank You Sir, will definnately be happy to start with the easy stuff first :p
 
1 - 5 of 5 Posts
Top