V-Twin Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
I brought my '06 street bob to the dealer after I had the download done because the yellow engine light was on.

Their computer says that there is a problem with the lambda sond... but my bike doenst have any lambda sond on the exhaust!!!

The problem could be that i bought the calibration cartridge in the states and that maybe international models could be different... but the italian parts catalogue says exactly the same part no for the SE calibration cartridge!!

ciao...

F
 

·
Humpin One Leg at a Time
Joined
·
455 Posts
lambda sond = o2 sensor, and unless i am mistaken the 06 Dyna's have o2 sensors on them.
 

·
Registered
Joined
·
62 Posts
alaskan302 said:
lambda sond = o2 sensor, and unless i am mistaken the 06 Dyna's have o2 sensors on them.
the HDI (international, as in non-US) spec '06 dynas does not have O2 sensors, but the older open-loop.

and yes Pippies, it could very well be that the US remap iswaiting for input from the sensors that's not coming.
 

·
Premium Member
Joined
·
3,289 Posts
easy to check whether the O2 sensor is on the bike. Check the pipes and you find a probe about the size of the spark plug bolted in the pipe about 5" from the exhaust flange. It has a cable attached to them wrapped in a protective ribbed plastic tube. There are two, one front and one rear. Not sure about the difference between international and domestic bike in that regard
 

·
Premium Member
Joined
·
135 Posts
What Bobber rider said.

Oxygen sensors are just for (US) domestic models. A US remap on an international model will probably make the check engine lamp come on (no input signal from oxygen sensors).

/Dan B
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #7 ·
ViennaHog said:
easy to check whether the O2 sensor is on the bike. Check the pipes and you find a probe about the size of the spark plug bolted in the pipe about 5" from the exhaust flange. It has a cable attached to them wrapped in a protective ribbed plastic tube.
Nice... I don't have the 02 sensor... :brows:

ciao...

F
 

·
Registered
Joined
·
34 Posts
Hi, In Australia our 06 Dynas have no 02 sensors, the sensor socket holes are plugged with plumbers brass caps, on my bike "06 FXDCI" we used the download for the softail no:34237-06, I have the tapered mufflers fits 95 and later Dyna's no:80061-00, and the S/Eagle Hi flow fits 02 and later EFI Models no:29440-99c, I have no issues with my bike all seem to run perfectly. Mite even run on the US models without "removed 02 Sensors"?????
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #10 ·
ViennaHog said:
Next time I pay a little more attention the detail, sorry I skipped right over a critical piece of information
I just meant that i "found" that I've no O2 sensor... :yes:

I thought that only aussie version where made without O2 sensor

ciao...

F
 
1 - 10 of 10 Posts
Top