V-Twin Forum banner
1 - 11 of 11 Posts

·
professional doof
Joined
·
690 Posts
Discussion Starter · #1 ·
ok here's the situation. the brake light works some times and doesn't others. then some times it just stays on. when i first noticed it it wasn't working so i checked the bulb and the fuse, and thery were good (obviously). it happens with both the front and rear brake so i'm not sure what the deal is. any ideas or possible solutions would be more than welcome, since i really don't want to take it to the dealer for them to try to figure it out. if i have to go that route it should be covered under warranty (i hope). thanks in advance.

josh
 

·
Premium Member
Joined
·
459 Posts
I had the same problem on my 03. It was corrosion in the tail light assembly from condensation.
 

·
Registered
Joined
·
645 Posts
Just to rule this out, do you have any LED modules in line?
 

·
Registered
Joined
·
6,413 Posts
First thing I'd do is check out the rear brake light switch. I've seen a bad switch there cause these kinds of problems. One wire on the switch is hot with the ignition on. Unplug the other one and see what happens.
 

·
03 Heritage
Joined
·
491 Posts
might be the switch

Especially if you've been fiddling in area of the front brake lever/brake switch. There is a little plastic nub at the end of the front brake switch in this area that is easy to break off. This would cause the brake light to stay on. This would not cause the brake light to not come on, so may not be your problem.
 

·
Registered
Joined
·
304 Posts
Mine was doing the same thing. Found that it was the tab that locks the switch housing/grip to the the handlebar clamp. It had broken off patially. This caused the switch (mounted in the clamp) to make intermittently. Was a great excuse to go with new chrome handlebar controls!
 
1 - 11 of 11 Posts
Top