V-Twin Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
I changed the oil last Sunday. I added 5 oz. short of 3 qts. of syn 3. The bike has a HD oil cooler on it so I added a little more than 2 1/2 qts. Anyway the bike rode fine for the 1st 40 miles or so. Yesterday she lost power about 10 mins down the road. It started breaking up and sounded like it would if it was over heated. Checked the oil and nothing was on the dip stick. 11 hours later when I was ready to leave work it still wasn't on the stick. Started it up and let it run a while then checked the level again and now it is up to the full mark. I road it home and it seamed ok. Then the same thing happened again and this time I feel that it is over heating.

Any ideas ? Do I need to call the dealer and bring it in for waranty work ?
I wanted to go to the bike show in Fort Worth on Sunday, It looks like I'm fucked !!!
 

·
Registered
Joined
·
136 Posts
Discussion Starter #3
No gauge. I just checked the level this morning and it is a little bit over the half mark ( cold ) were it should be. I'm bringing it in to the dealer and let them mess with it. Thanks for the reply.
 

·
Premium Member
Joined
·
3,288 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #5
ViennaHog sorry to hear about your experience. I went ahead and and had the bike picked up and brought to the local dealer. Well they test road it and found nothing wrong with it. The oil levels were ok and it didn't overheat for them. I know I wasn't dreaming even my wife said the bike sounded like a dirt bike as I cranked past the house on the road behind us. They said they will take it out again and see if it does it. My boss sugested I try the other dealer in town, they have a better reputation so I hear. I will keep ya'll posted.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #6
Well I just got off the phone with the dealer and they said the tech took it for a 40 mile ride and it didn't overheat. Could there have been a blockage and it cleared it self out ?
 

·
Registered
Joined
·
66 Posts
Isnt it amazing how a bike will never do anything wrong when magically blessed by a dealer tech riding it?

Just a thought, perhaps you have a bad filter thats blocking oil flow when the relief valve isnt opening properly??? Hope you get things worked out!
 

·
Registered
Joined
·
136 Posts
Discussion Starter #8
Yeh the darn thing ran fine when I picked it up. Put about 80 miles on her and not even a cough. At lease they didn't charge me for letting them ride my bike:huh:
 
1 - 8 of 8 Posts
Top