V-Twin Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
I have a '06 FXDLI that has the 95" jugs, stock heads, SE204 cams and Rush slip-ons. The Stage II download wasn't working. The bike had a part throttle misfire, and popped like a howitzer out of the exhaust during deceleration. If it was loaded below 2200 RPM it was ok, but around 2500-2900 at part throttle it was not happy at all. So, I brought it back in with my complaints. The dealer's service guy found a new map from HD designed to address the O2 sensor bikes that have been uncorked.

Well, it's a little better, but I've decided to have them put the SERT to it and tune it on the dyno. BTW, the last tank was 29mpg. It goes like hell once you get past the stumble, but I have the sneaking suspicion that they will have to inactivate the 02 sensors to cure the problem. Anyone have any comments?
 

·
Average Dude
Joined
·
6,263 Posts
Do you know if they swapped injectors? If they put in larger ones, that may be part of the problem.
 

·
Premium Member
Joined
·
11,928 Posts
on my 06 fxdi, i experiienced a similar problem. my rear injector went bad.

you still need the sert or other tuning ware like a thundermax.

the 06 FI bikes are lean from the factory, they are lean after the download.
example.: new 06 dyna
stock, lean misfire, runs hot.
stock with flash, seems to run ok, but still a lean plug reading, open up the exhaust or A/C and it will spit and backfire from lean condition.
stock with 25 degree injectors, rich plug reading.
stock with 25 degree injectors, slip ons and modded A/C, it goes lean again!!

you need to tune the bike! eliminating the 02 sensors will not help as the only time you run in close loop is at light cruise.
 
1 - 4 of 4 Posts
Top