V-Twin Forum banner
1 - 5 of 5 Posts

·
EASY DOES IT
Joined
·
8,914 Posts
Discussion Starter · #1 ·
Not the same problem as before thank the Harley gods but similar, I purchsed the heads from a member across the country (they are pristine) in the belief that all twin cam heads wre created equal...the only exception would be that '05 valve seals and the new port configuration for the '06 heads.

Alas I get these heads back (what a super job Steve does) and they have this "thing" sticking out next to the intake...it may be oldtimers disease but I just don't remember a sensor or such hangin' out of my '04 softail heads...If indeed this is some sensor for EFI is there a way to get rid of and plug this fugy thing???

If it belongs and I've forgotten chalk it up to a poor memory...but please hurry, this has been way more stressful a build than needed.

Thanks,
John
 

·
Premium Member
Joined
·
460 Posts
not expert here, but i think youre referring to the temp sensor. I believe it is a blind hole so you can just remove the sensor and go forward....
 

·
Administrator
Joined
·
11,287 Posts
Sounds like the Head Temp sensor. You can remove it and I believe a 1/2-20 button head will fit.
 

·
Premium octane member
Joined
·
7,381 Posts
I ran into the same problem with evo heads a while back. Springer and atengnr are correct. Your bike is carb so just pull sensor out and chuck it...Or save for a buddy with efi.....Keep us posted up on the build and good luck.
 

·
EASY DOES IT
Joined
·
8,914 Posts
Discussion Starter · #5 ·
Whew...thanks guys...you have no clue how relieved I am...
 
1 - 5 of 5 Posts
Top