V-Twin Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Just bot an '03 HD RK classic.

And the cruise does not work. The light on the left handle bar comes on, but I am not able to activiate the cruise using the right side controls and of course the light on the right side does not come on.

Any thoughts on how to fix this or troubleshoot?

Thanks for your help.
 

·
2005 Road King Classic
Joined
·
1,632 Posts
For what it's worth, my 05 had to have the right switch replaced. I have heard that it is common. I would do a diagnosis from the service manual.
 

·
Registered
Joined
·
7 Posts
I have an 03 RKC and had the same problem. It would work intermittently. Sometimes not at all like yours and sometimes would shut off on it's own.

Happened in Sturgis this year just before I started my 1100 mile journey home! Then after leaving Deadwood it started working. Once I got home the dealer replaced the right control switch. No problems since.

Hope this helps.
 

·
Registered
Joined
·
43 Posts
Abel,
My 05 RKC currently has the same exact problem. Mine is a result of swapping out the housing and switch buttons. I apparently tapped the switches a bit too hard with the rubber mallet during the install. Anyways, since you mentioned just buying an '03 model, the previous owner may have done the same mistake as I. --hope this helps

BBCOD & Sonny,
What did the switch fix $run ya? Did they only replace the one switch? I asked my HD dealer about the switch and they told me I'd have to buy the whole c/control for around $350, because they did not sell the switch by itself. I'd hate to drop that kinda cash, when I could try to get a switch. I'm also comtemplating on opening the housing and seeing if could fix the switch itself, at the risk of causing more damage.
 

·
Registered
Joined
·
645 Posts
lol.. nando. no offense but what in Gods name where you using a mallet for, on your switches? lol..
 

·
Registered
Joined
·
43 Posts
I know....sounds funny, actually makes me laugh when I think about it now. But, you'd of done the same, after your thumb started throbbing from trying to push on that last c/crontrol button onto the switch. The c/control button simply did not slide on. It needed a little "help". When it finally did go on, it stuck out as if it were going to fall off at anytime. So again, I lightly tapped it with a rubber mallet--obviously too hard.

Anyways, I don't want to take away from Abel's thread, I just thought this would help him. And maybe get a part number for the switch from BBrownCod or Sonny.
 
1 - 6 of 6 Posts
Top