V-Twin Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
I just replaced tre front motor mount on my roadking. I experience now some heavy vibrations on the front end of the bike. Is this normal ? Will this go away ? The FMM is original from HD.
 

·
0043--Licensed to Doof!
Joined
·
4,369 Posts
It will go away when the new one tears. Unfortunately, this seems to be the norm. I just did the replacement on my Electra Glide, it shakes at idle now worse than it did.
 

·
Premium Member
Joined
·
269 Posts
What I've been told is that the 2007 and newer mounts have been made to be 'stiiffer' as the 2005/2006 ones were wearing out too quickly. I have a 2006 Ultra, and I noticed my girlfriend's 2007 Road King shook a lot more at idle than mine... until they put a new front mount in mine, then they shook just the same.

I pulled out the new HD mount and put in a Velva-Glide mount. Much smoother, and the VG mount is much easier to install/replace than the current HD ones.
 

·
<><
Joined
·
3,971 Posts
Geezer-Glide said:
It will go away when the new one tears. Unfortunately, this seems to be the norm. I just did the replacement on my Electra Glide, it shakes at idle now worse than it did.
Same here. Wish I had the old one back.
 

·
Registered
Joined
·
124 Posts
Discussion Starter #6
upside down !

i found out the the new mounts need to be installed with the text"made in china" ( ahum ) upside down. this is what is written in a HD service bulletin.
i will tear all apart again and install it upside down. hopefully it will help. weather is **** anyway overhere...
 

·
repeat offender
Joined
·
691 Posts
Be careful, you always install parts that say "made in china" upside down in the USA... If you are installing them in Europe, you may need to install it sideways!!! :hmmm:
 

·
<><
Joined
·
3,971 Posts
trustinHD said:
i found out the the new mounts need to be installed with the text"made in china" ( ahum ) upside down. this is what is written in a HD service bulletin.
i will tear all apart again and install it upside down. hopefully it will help. weather is **** anyway overhere...
I don't understand. How would I check mine to see if it's installed right side up?
 

·
Registered
Joined
·
6,413 Posts
Check this thread out. The .pdf inst sheet is there. At the time this was published, they didn't have "made in china" on them.

HERE
 

·
Premium Member
Joined
·
269 Posts
ibilintuc said:
What's a Velva-Glide mount?
It's a non-HD replacement mount made by V-Thunder. Claims to be longer lasting and less vibrations.

"Reduce transmitted engine to frame vibration by 20% just by replacing your OEM front mount with this improved version. The Velva Ride system utilizes a powder coated or natural finish 1/2" thick aluminum engine plate and two separate isolator mounts that are made from a semi-soft Urethane."

I can also add that it's MUCH easier to install or remove than the current HD mount. The HD mount is in one piece and needs a good deal of clearance to get in or out of the frame hole. I had to fight with it for a long time to pry it out. The Velva Glide mount's urethane parts are in two pieces, so the bottom piece can just drop out once the main bolt is off, leaving the top part to slip out with much less clearance required.
 

·
<><
Joined
·
3,971 Posts
Ed Y said:
Check this thread out. The .pdf inst sheet is there. At the time this was published, they didn't have "made in china" on them.

HERE
Thanks. Printed the .pdf, to the garage, even saw the upside down CHINA on there. It's installed correct alright. I ran through all the clearance/alignment steps -- no change.

Guess I'll make the switch to Velva Glide... if that's the preferred mount?
 
1 - 11 of 11 Posts
Top