V-Twin Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
I’m having some trouble with my front brakes. I have a dual disc front end with an 11/16 master. It stops and responds well. It’s not spongy at all.

The problem is when I hold the front brake, slowing down over bumps or sometimes at idle even, the system seems to lose pressure suddenly and the lever goes to the bars. If I release the lever and squeeze it again, all is well. Do I need to rebuild the master? Does that sound like I have air in the system?
 

·
Registered
Joined
·
69 Posts
If you are unsure if the master has ever been rebuilt, pull it down and rebuild. Do not try to hone bore and make sure all parts stay exceptionally clean. The drag specialties kit is of very good quality; Made in Japan where all my precision tools come from. Then fully flush and bleed the rest of the system.
 

·
Registered
Joined
·
542 Posts
I agree, it's the master cylinder. You prolly won't find it's stocked by a HD Dealership anymore and will have to buy an aftermarket kit. The biggest problem will be the rubber end cap on the end. If you screw it up you'll have to buy a whole new kit. Ask me how I know. LOL! Best method I found is to use a socket of the same diameter and press it in carefully and evenly. Then make sure to flush the entire system and of course, bleed correctly.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #6
My lines are old, but they're braided. Sounds like time to rebuild the master cylinder. Thank you.
 

·
Registered
Joined
·
542 Posts
If you're not leaking anywhere it's just a worn plunger seal. The fluid is going past it back into the reservoir.
 
1 - 7 of 7 Posts
Top