V-Twin Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Got an oil leak. Took a 120 mile ride today to get some more break-in miles clocked, when I got home noticed a small drip under the bike. Looked underneath and lo and behold---engine oil. Residual oil on the undercarrage---an effing mess to clean up on a 300 mile bike. Oil dipstick showing approx 1/2 quart low.

The dealer is going to look at it on Monday. Dissed, but I guess this can happen and as long as it's taken care of and there's nothing else............

Mike M
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
Not coming from the drain plug, Jimmy. One of those mystery leaks. Doesn't seem to be coming from the oil pan area but clearly, there is a leak. Not pissing out, but enough to drop one small drip on my driveway when I got back from a 150 mile ride. This morning I looked to see if I could find the leak or where it was originating from. No dice. Just not the most suspect spots like the drain plug or oil filter and I can't get my head underneath enough to find it.

Not a lot of oil on the underside, but definitely some area is leaking---looks like I was wrong on my original post, dipstick reading 1/4 inch below full indicator.

Dealer picks it up tommorrow and we'll see.

Mike M
 

·
Registered
Joined
·
1,366 Posts
That sucks. Looks like we are in the same mile range on bikes. I have been worried about the dreaded oil leaks. Hope the dealer takes care of it. Keep us posted.......
 

·
Traveling Man
Joined
·
1,272 Posts
The boneyard01 had a leak similar to what you are talking about on his Heritage and it ended up being a primary seal. They actually had to do the job twice under warranty because they didn't do it right the first time. No more problems since.

Later,
 

·
Registered
Joined
·
48 Posts
Discussion Starter #6
Fifth Gear, interesting you should say that. It seemed like I was tracing the leak to the primary cover. I had one of those chrome inner primary covers installed and the leak seems to show up in that area. The frame has oil on it directly under the primary so it's probably it.

Thanks for the tip.

Mike M
 
1 - 6 of 6 Posts
Top