V-Twin Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
262 Posts
Discussion Starter #1
HIPPO,
Have a 03 FLHTCI with 4100 miles, stage 1 and SE slip-on's. The engine has a noticeable click at all times above 60 mph. Sound similar to a lifter in a car engine. No other problems, bike runs great. Any ideas what I need to look for?
Thanks:confused:
 

·
Registered
Joined
·
2,300 Posts
The 03's are usually pretty quiet. If is sounds like a lifter it probably is a lifter it just seems unusual it would only do it above a certain speed. May want to ride it at that speed in a lower gear to see if it is engine speed or road speed related. Noise transmits in strange ways on these bikes, it wouldn't be the first time a heatshield or a horn bracket (where it attaches to the heads) that was loose sounded like a engine noise.
 

·
Premium Member
Joined
·
262 Posts
Discussion Starter #3
HIPPO,
Thanks for the quick reply, I will do as you recommend and let you know the results. Seems to me though, I hear the noise when I over accelerate, meaning, if I easy through the gears and keep the rpm's rather low, I never hear the noise. Actually, I have learn to control the noise by shifting just before the clicking begans. Hope this make some sense. I haven't been to the stealer yet but plan on a visit very soon.
 

·
Registered
Joined
·
2,300 Posts
Might be a bit of detonation the way you describe it now, but it's extremely unlikely to detonate at a steady speed.

Seems like some of the Delphi bikes have what appears as minor momentary detonation under hard acceleration just before the ECM retards the timing. They claim it is normal.

Since it can be tuned out I disagree. Perhaps they mean it is normal for the particular bike at the present state of tune.
 
1 - 5 of 5 Posts
Top