V-Twin Forum banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
258 Posts
Discussion Starter · #1 ·
When I plugged my fuel line back into the tank fitting, the damn thing leaks like crazy. I've tried cleaning the fitting, greasing the fitting, etc. It still leaks badly and no fuel is getting to the injectors. What do I do?:duh?:
 

·
Arrogant Bastard
Joined
·
1,264 Posts
Check the o-rings on the fitting. Also make sure the chrome retaining ring is pulled firmly into place, it doesn't always snap back on its own. I've had mine off a few times and always pull the collar up to insert the fitting then pull it back down.

Joe
 

·
Premium Member
Joined
·
258 Posts
Discussion Starter · #3 ·
Uh..Oh..you said O-ring....maybe I lost it. Is there an o-ring between the fuel line and the tank fitting?
 

·
Arrogant Bastard
Joined
·
1,264 Posts
michael101 said:
Uh..Oh..you said O-ring....maybe I lost it. Is there an o-ring between the fuel line and the tank fitting?
Michael, there is an o-ring IN the tank fitting. It's pretty small and about 2/3 of the way up inside the fitting. If it's missing or has a nick in it you get a leak. Also the fuel line really pushes into the fitting hard. If your not burying the male end into the tank fitting it won't couple and let the retaining collar go back down into the locked position.

Joe
 

·
Premium Member
Joined
·
258 Posts
Discussion Starter · #5 ·
jasilva said:
Michael, there is an o-ring IN the tank fitting. It's pretty small and about 2/3 of the way up inside the fitting. If it's missing or has a nick in it you get a leak. Also the fuel line really pushes into the fitting hard. If your not burying the male end into the tank fitting it won't couple and let the retaining collar go back down into the locked position.

Joe
I guess I did something to the o-ring then. The retaining collar snaps back into place, and I have the fuel line fitting all the way in....oh well....

Thanks for the help
 
1 - 5 of 5 Posts
Top