V-Twin Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
715 Posts
Discussion Starter #1
OEM starter cover 05 Ultra. Damn thing keeps coming loose. The mount that the cover attaches to with one screw appears to only slip over the two "threaded" studs on the starter. Is the chrome starter cover mount supposed to be secured to the two studs on the starter with nuts?
 

·
Longtime Asphalt Cowboy
Joined
·
3,291 Posts
sixgun95 said:
OEM starter cover 05 Ultra. Damn thing keeps coming loose. The mount that the cover attaches to with one screw appears to only slip over the two "threaded" studs on the starter. Is the chrome starter cover mount supposed to be secured to the two studs on the starter with nuts?
The mounting bracket attaches to the two starter studs. Then the chrome cover mounts with a single screw in the middle of the cover attaches to this bracket. Use blue (242) LocTite on the screw holding the cover on. Have removed/replaced several of these over the years and never had one come loose that I can remember.

Harley should put 2 bottles of LocTite in the saddle bag of every Harley sold..

o~\o
 

·
Longtime Asphalt Cowboy
Joined
·
3,291 Posts
sixgun95 said:
Is the mounting bracket secured to the studs on the starter with nuts? When I removed mine, it only had the screw in the middle. Thanks!
Yeah, that's right. The bracket attaches to the starter with two nuts and the chrome covers then attaches to this bracket with the "one" chrome screw. LocTite that screw to the bracket.

o~\o
 
1 - 5 of 5 Posts
Top