V-Twin Forum banner
1 - 20 of 25 Posts

·
Premium Member
Joined
·
308 Posts
Discussion Starter · #1 ·
Just wondering if anyone has put on a chrome inner primary and had this problem. I had it put on by a dealer and now all around the edge of the inner primary you can see the unpainted part of the engine case. Sticks out like a soar thumb! I was in a real hurry when I picked it up and didn't notice it. I called the dealer and they said that they could paint that area. He said that the primary is dowled so it can't be adjusted. Is this normal or did they put some after market part on, or what??? Any input would be great!
 

·
Premium Member
Joined
·
64 Posts
Doesn't look right to me and I suspect it didn't look right to the person who installed it. The chrome inner primary on my touring bikes fit perfectly. I'd ask for another one.

Dan
 

·
Premium Member
Joined
·
308 Posts
Discussion Starter · #3 ·
Thanks for your input. I am going to the dealer on Friday and I that's exactly what I am going to do. These guys have been real good so far, it was when they suggested to paint it what pee'd me off.
 

·
DILLIGAF
Joined
·
35 Posts
Labor

I couldn't tell from the picture. But I do have a question. How many hours labor did they charge you for?
 

·
Premium octane member
Joined
·
7,381 Posts
I have never done one on a dyna model, but the couple i did on softails and touring models were mint. No visible transition like that. I wonder why tech did not question it?
 

·
Premium Member
Joined
·
308 Posts
Discussion Starter · #6 ·
copmsaw said:
I couldn't tell from the picture. But I do have a question. How many hours labor did they charge you for?
Actually they didn't bill me yet. I picked it up last Friday late and he said that he would just send me the bill. When I talked to him about this on the phone I told him I would be down with it on Friday this week and I would settle up with him. These guys have been really good to me so far. The reason I posted this was to see what other people thought. Like if touching up the case was normal or if this part is just defective.
 

·
Screw Prozac...Just Ride!
Joined
·
138 Posts
I have a friend that bought an aftermaket inner and he had leaks too. Could the problem be that this is not a HD genuine??

Just throwing it out there.....
 

·
Premium Member
Joined
·
308 Posts
Discussion Starter · #8 ·
willy said:
I have a friend that bought an aftermaket inner and he had leaks too. Could the problem be that this is not a HD genuine??

Just throwing it out there.....

Is there a real way of telling if it is genuine or not?
 

·
Knower of Stuff
Joined
·
1,978 Posts
Only way to tell if it is a genuine H-D would be to pull the outer primary and look at the stamping on the inside of the inner cover.
Your bill should also list the H-D Part number if they billed you for an H-D part.
 

·
Registered
Joined
·
200 Posts
I just installed one and it had leaks. I took it back and the dealer attempted to fix but it still leaked. On the 2nd attempt they found it had a hairline crack in it so they put a new one on. The dealer said they have had a lot of problems with the seals that were pre-installed. Mine fit perfectly and did not have the visible mismatch.
 

·
Premium Member
Joined
·
1,298 Posts
jaystone said:
Is there a real way of telling if it is genuine or not?
Mine doesn't fit like that. They may have used aftermarket. Make them prove it. It will have an HD number inside.
 

·
Incredible
Joined
·
3,029 Posts
jaystone said:
Just wondering if anyone has put on a chrome inner primary and had this problem. I had it put on by a dealer and now all around the edge of the inner primary you can see the unpainted part of the engine case. Sticks out like a soar thumb! I was in a real hurry when I picked it up and didn't notice it. I called the dealer and they said that they could paint that area. He said that the primary is dowled so it can't be adjusted. Is this normal or did they put some after market part on, or what??? Any input would be great!
Looks like a pretty ragged install job. :yikes: :yikes: Not the kind of people I would trust to do work on my bike again once they fixed that error. Definitely don't trust them working on the motor. That may end up being a nightmare you wish you could wake up from.
 

·
Premium Member
Joined
·
1,744 Posts
not right the chrome inner primary should fit like the one taken off. And I assume it didnt look like that with original.My guess aftermarket or defective.
 

·
Premium Member
Joined
·
308 Posts
Discussion Starter · #14 ·
Thanks for all the input and advice. Great forum!
 

·
Premium Member
Joined
·
550 Posts
I just looked at mine, and it appears that the chrome inner primary is a bit larger than the engine case, so nothing shows at all. Mine also is a HD part and was dealer installed prior to initial delivery of the bike.
 

·
Premium Member
Joined
·
308 Posts
Discussion Starter · #17 ·
Leaving in about a hour, I will let you know when I get back.
 

·
Premium Member
Joined
·
308 Posts
Discussion Starter · #18 · (Edited)
Well, it didn't go as well as I thought it would. The service manager was the worst. He said, "I can't believe that bothers you" and told me if I wanted to try another one that I would have to pay for it all over again. He said it is a machine and it can't be perfect and even if we did it again that it would probably be the same. Suggested the paint thing again. The parts manager said though that he would try and work it out to get it done again, but maybe I would have to pay for the labor and that Harley would not warranty that part.(which is a Harley part) He said that he would just have to put the old one into their stock. I just didn't feel like arguing so I left it at that for now. I'll see what the parts manager comes up with. I think what I am going to do is just get another one put on by another dealer and see what happens, or check into getting my stock one chromed at Brown's then having it installed. Then go back and show them the difference. I don't really want to spend the extra money, but in this case I really don't care. Just want to prove a point. On the other hand we took my wifes bike in for the 1000 mile service and they charged us $83. So what the heck???!!!


Any suggestions on what to do next?
Jason
 

·
Premium Member
Joined
·
5,217 Posts
Yes, you paid for a product and a service, and it is not right! I would demand to speak to the next in line! Then when resolved don't go back to that dealer! You should not see that ridge! Are you positive it has an HD # on it or are you going with the part managers word?? If it is not an HD part, which I suspect it is not, YOU GOT EM!!!!:thumbsdn:
 

·
Premium Member
Joined
·
308 Posts
Discussion Starter · #20 ·
According to my receipt it is the correct part number. I am going to get it changed and check the part number if it is correct I feel Harley should warranty it. The dealer said they wouldn't, but I will just have to give Harley a call myself. Especially if the new one fits the way it suppose to. If it is some other part number then I'll have a bigger problem with them! It will be interesting for sure. I have contacted Browns Plating also and they chrome my stock one for $235, might go that route. I have already told them what the problem is with the one that is on there, they said the that could be careful on the edges not to take to much metal off so it will fit properly. That is what I feel the problem is with the current one, which I would consider a defect! Thanks for the advice.

Jason
 
1 - 20 of 25 Posts
Top