V-Twin Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i have a 2012 Ultra Classic Electra Glide CVO 110 screaming eagle. The problem I am having is that on occasion I will get the smell of burning oil. It’s not all of the time only once in awhile. Any ideas why I would be getting this smell? Bike has 20,532 miles on it.
 

·
Super Moderator
Joined
·
3,042 Posts
Too much fuel, bad valve seals,tired umbrella valves in the heads, old diluted or thin engine oil.Just to name a few possibilities.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
The oil level hasn’t changed on the stick. I bought the bike 2 weeks ago from a Harley dealership I was thinking of pulling the plugs checking them and also doing an oil change. I should also call the dealership and see if they did a full service on the bike because it sat in storage at the dealership for a little over a year. I know I should of asked them if they serviced them before I took it home but didn’t think about it. And the one owner before me was an older gentleman so I know it wasn’t best on.
 

·
Registered
2017 CVO breakout
Joined
·
14 Posts
If you purchased the bike from the dealership most likely a oil change was performed. I would check for oil when they removed the oil filter sometimes there is oil that was not wiped down after an oil filter install. Another possibility is too much oil the air cleaner might have some oil coming out the vent tubes inside the housing. As mentioned before could be a lot of possibilities but check the simplest ones first. If you can't find anything take it back to the dealership and tell them you smell burnt oil.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I did notice i I only started getting the oil smell once in awhile when I changed from the screaming eagle slip ons to the Vance and Hines monster ovals so could that be the problem? As far as I can remember anyways....
 
1 - 6 of 6 Posts
Top