V-Twin Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
81 Posts
Discussion Starter · #1 · (Edited)
04 FLHTCI the front brake pads sound like they are rubbing very lightly on the discs. Not very loud but enough to be heard when moving at low speed. If you put slight pressure on the front brake lever the noise goes away. Is this common? For some reason it bugs the s**t out of me. Is there a fix or do I need to just turn the radio up a little?

Thanks,

:blink:
 

·
Premium octane member
Joined
·
7,381 Posts
if that annoys you, wait until they start sweeking.....mine did at 2500 miles. I went with hd floating rotors and z brake pads.....had never heard a peep out of me or the bike since...:)
 

·
Registered
Joined
·
68 Posts
Dave, I have the exact same thing going on with my '05 FLHTCI. I didn't notice it when new, but noticed it after the 1000 and 2500 mile services. Tech at stealership said it's adjusted that way. I don't hear it when I'm moving, unless I'm going over a bridge with a fairly solid side wall, or I'm close to the wall of a building. Floating rotors and Z pads will definitely help.
 

·
Registered
Joined
·
9,150 Posts
Heard it bad when new... thought something was scraping. Also had bonus brake squeeking. After 4-5k I don't notice the rubbing, maybe quieter, and the squeeking has stopped. All normal.

It will probably all come back for my enjoyment when I get the front brakes done.
 

·
Humpin One Leg at a Time
Joined
·
455 Posts
Louder pipes fix the problem quite well. Otherwise go get youself some Lyndall Z + pads. They make little to no noise. To answer your question, Yes this is a common problem.
 
1 - 8 of 8 Posts
Top