V-Twin Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
i had a bdl open installed on my 90 fxsct a year ago, about 1200 miles on it, and im having the same problem as from day one. the jackshaft gear doesnt line up with the ring gear and i can hear it hitting. it does this more than half the time i start it. the shop that installed it say thats common and another harley shop said thats normal. doesnt seem right to me. any thoughts on this, thanks.
 

·
Administrator
Joined
·
11,242 Posts
My BDL came with a starter also and I have not had that problem. What exactly is interfering? Are there any marks to indicate the exact issue?

With a old Primo belt drive I had to file the teeth on the starter gear to get it to engage properly. Not that it is the same as your problem but it may take some modification to corect the issue.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #4
well found out my battery was really low, and shot. replaced it and seems to have fixed the starter problem, at least it only does it 1 in 5 times instead of 2 out of 3.
 

·
Administrator
Joined
·
11,242 Posts
hotrod351 said:
well found out my battery was really low, and shot. replaced it and seems to have fixed the starter problem, at least it only does it 1 in 5 times instead of 2 out of 3.
Good to hear you found a problem, or at least made it better.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #6
yeah, its messed up when everyone wants to shoot craps with my money. one says it this and another says it that, cool if they paid for it. thanks, im on the road again and running strong.
 
1 - 6 of 6 Posts
Top