V-Twin Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, new to this board and need help. My '99 Road King has bad wobble from 85 - 95 mph. Tried 3 new sets of tires (Avon, Bridgestone, Dunlop), and 3 new sets of wheels. All balanced and re-balanced.
New bushings in swingarm.
Just had new steering head bearings installed yesterday.

The problem remains...what now?

I'm tired of spending money chasing this problem!!
 

·
Premium Member
Joined
·
1,389 Posts
Rob(in S.C.) said:
Hey guys, new to this board and need help. My '99 Road King has bad wobble from 85 - 95 mph. Tried 3 new sets of tires (Avon, Bridgestone, Dunlop), and 3 new sets of wheels. All balanced and re-balanced.
New bushings in swingarm.
Just had new steering head bearings installed yesterday.

The problem remains...what now?

I'm tired of spending money chasing this problem!!
Make sure bike is aligned then www.true-track.com
 

·
0043--Licensed to Doof!
Joined
·
4,369 Posts
Rob(in S.C.) said:
Hey guys, new to this board and need help. My '99 Road King has bad wobble from 85 - 95 mph.
Are you trying these speeds with the bar mounted windshield on? That causes the bars to occilate at speed.

Of course there's that law thingie...... speed limit is 70MPH!! :whistle:
 

·
Registered
Joined
·
304 Posts
Windshield on or off

Mine does that too... but it smoothes out at about 105 mph:D Just kiddin of course. Wind, road conditions and a lot of other things can effect this. Is this an actual wobble or is it just feeling a little squirrelly?? Mine does get a little wobbly with the windshield on at those speeds, so what I do is SLOW DOWN.
 

·
Registered
Joined
·
26 Posts
My first thought would be the wind screen. Second thought is that the front wheel is out of align, and my last and worse thought is that you have been replacing the wheels with the wrong wheels. If they are off another model or made for a different model there is a chance the offset clearance my be off. Or if these are wire wheels they could be out of true. But after 3 sets I would think the shop would have checked this. But again my first guess is like Geezer-Glide said it could just be you are driving over the speed limit and the wind screen is giving you the slight vibration. Hope you figure it out. Ride Safe.
 

·
Registered
Joined
·
473 Posts
Just installed Sta-Bo bushing inserts on swingarm. Have only 200-miles on them. Ride is stiffer and feel more road vibration. Wobble is mostly gone so I will make a fair judements after 1000 miles. I was told they break-in and the ride gets better. Will keep you posted...
 
1 - 7 of 7 Posts
Top