V-Twin Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
574 Posts
Discussion Starter #1
I tried to put a deep bezzel on my 06 EG and the fit is terrible, I mean there is a 1/4" gap around the whole bulb, I called the dealer and even went by one and they didn't have any answers, one dealer said that it was sort of common for this to happen, soooo has it happened to any of you?:huh:
 

·
?????
Joined
·
3,531 Posts
Tnford27 said:
I tried to put a deep bezzel on my 06 EG and the fit is terrible, I mean there is a 1/4" gap around the whole bulb, I called the dealer and even went by one and they didn't have any answers, one dealer said that it was sort of common for this to happen, soooo has it happened to any of you?:huh:
I think the fit is different from bike to bike. I put a frenched ring on the head light of the 05 EG Classic that I had, it fit pretty good. I took the exact same ring off the 05 Classic and put it on my 06 Ultra and it has a good 1/4" gap like you have, kind of left me scratching my head.
 

·
Premium Member
Joined
·
111 Posts
i too jsut put rings on my 06 RKC. Have a gap in all 3 rings. I am going to take them off this weekend and do the following:

disconnect light fixture
bring in house to warm and and the metal upa bit
make sure that light is sitting firmly and all the way into the ring
take back outside and have a friend or foe hold the ring firmly in place as I screw it back down.

When I originally put them on I did it myself and could have used another hand ot two. Good Luck.
 

·
Forgetter of Things
Joined
·
2,657 Posts
I have the 1/4" gap between the trim ring and headlight lens on my '06 ultra, too. and i've looked at others that have the same gap.
 

·
Ridin' with the King
Joined
·
1,352 Posts
The HD one sucks. Get the one from CCI or Drag. That whole thing where you put the new one over the old one is crap IMHO and the aftermarket ones mount like the regular trim ring.
 

·
Registered
Joined
·
8 Posts
When I had a Sportster I put one on (HD brand) and it fir perfectly. So when I tried to do the same on my 05 EG Standard I was surprised to find the gap. The dealer said that HD went with a different, shallower buld on the 05 and that was the cause of the gap. I returned the trim ring.
 
1 - 6 of 6 Posts
Top