V-Twin Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi guys I'm having a hell of a problem. I bought an Independence chopper with a '98 dyna Evo wide glide engine in it. It had a cracked rocker box spacer on the back cylinder so I replaced the spacer put the umbrella valve in the spot next to the carb. and put everything back right. I've gone over three times to make sure the damn thing just billowing smoke though ever since I can't get it to stop then I'm on the freeway today I finally take it out for a ride say f... it hopefully im just burning off some oil. I'm on the freeway doing about 70 and the goddamn oil cap blows off hits me right in the leg throws bout a quart of oil all over me and the bike. luckily being that's where my legs stradles ( my oil pan/box is under my seat) I was able to kind of hold the oil cap in place and save it. so I pull over and I'm hearing like a grinding sound coming from my belt drive area when try to put it back in gear and try to move and it just it didn't want to move at all I mean it would roll a little bit but it wasn't liking it and now it won't start. So I got it towed home please help. What did I do to this thing and how can I what do I need to do to fix it? I do want to mention that I swear one of my oil lines you know I got the three oil lines down there I could swear that one of them never has any oil in it ever when I say like the middle one I have to go out there and look at it see exactly which one but it's always just clear you know I never see any oil in it.. the first two pictures are of the gunk that was coming out of my exhaust the third picture is just a picture of the bike and the last three pictures are of the hose that never has any oil in it
 

Attachments

·
Registered
Joined
·
29 Posts
maybe excess crankcase pressure and the breathing system not working. evos getting old. unless it has been done, i would replace carb boot and diaphragm, intake rubbers, umbrella valves and plastic breather gear as part of routine maintenance to any evo i might get. the other umbrella valve you didnt replace is probably hardened and not doing its job. if the plastic breather gear has shed its teeth you will pull your hair out fixing things.only way to know is look. if the oil pump ate your plastic gear teeth it may or may not be ok. those particular oil lines tend to harden with heat and time. grinding into gear separate and may just be a matter of clutch and cable adjustment.
 

·
Registered
Joined
·
9,102 Posts
i think you have a couple independent issues overlapping..,
did you ever add oil to the oil tank,, after the bike had been sitting? or fill the tank before starting and running the engine a few minutes? this could be overfilled, due to the check ball in the oil feed line leaking into the case
.alot of evo engines do this... it could also explain, smoking heavily and blowing the oil.cap..... if not over filled,,, look for a crimped.over vent line or clogged vent line. looking under the cam.cover is now a good idea, if you found no issues with the oil level...

it is not possible to diagnose issues over the internet

.
...
 
1 - 3 of 3 Posts
Top