V-Twin Forum banner

1 - 19 of 19 Posts

·
Premium Member
Joined
·
33 Posts
Discussion Starter #1
I would appreciate any feedback from 103 owners out there they may have this problem. My 2010 Ultra Limited currently has 16k miles. Every since the bike had approx. 10k miles, I have been having an intermitten problem with a very loud ticking noise. This occurs after the bike has been ridden for a long distance and then the engine is stopped and left off for some time. Upon restarting a very loud ticking noise comes from the engine and will continue for approx. 20-30 seconds and sometimes longer if after an oil change. Again, this does not happen every time and I tried to make it happen at my HD dealer but (my luck) it didn't do it that time. Any ideas on what this may be?
 

·
Premium Member
Joined
·
33 Posts
Discussion Starter #3

·
Registered
Joined
·
259 Posts
no noise with my 103. Sounds like a lifter that isn't pumping up completely???
What if any work have u done or had done to this motor??
 

·
Premium Member
Joined
·
1,790 Posts
I would appreciate any feedback from 103 owners out there they may have this problem. My 2010 Ultra Limited currently has 16k miles. Every since the bike had approx. 10k miles, I have been having an intermitten problem with a very loud ticking noise. This occurs after the bike has been ridden for a long distance and then the engine is stopped and left off for some time. Upon restarting a very loud ticking noise comes from the engine and will continue for approx. 20-30 seconds and sometimes longer if after an oil change. Again, this does not happen every time and I tried to make it happen at my HD dealer but (my luck) it didn't do it that time. Any ideas on what this may be?
Radar, Is your Comp sproket stock ?? I 've heard all kinds of noises on my FLHTK. Thought they were the valve train. After I had my Comp sproket replaced w/ SE one it was a big difference in the engines sound, or should I say primary noise...
 

·
Premium Member
Joined
·
33 Posts
Discussion Starter #9 (Edited)
Radar, Is your Comp sproket stock ?? I 've heard all kinds of noises on my FLHTK. Thought they were the valve train. After I had my Comp sproket replaced w/ SE one it was a big difference in the engines sound, or should I say primary noise...
I do have the stock compensator. When I could not duplicate the noise at the Harley dealer the HD Tech mentioned that it could possibly be the compensator. But would the compensator do this intermittenly or would it be constant?
 

·
Premium Member
Joined
·
943 Posts
The 11' has the SE comp installed factory.
I use 25-60 when the weather is warm, 20-50 spring and fall. Found the heavier stuff kept it quietter.
 

·
Premium Member
Joined
·
1,790 Posts
I do have the stock compensator. When I could not duplicate the noise at the Harley dealer the HD Tech mentioned that it could possibly be the compensator. But would the compensator do this intermittenly or would it be constant?
Yes intermittenly, I can be on the interstate going 70-75 mph and out of nowhere a noise will appear, I can give it a little gas and It'll get quiet, slow down is same thing.. Now this is with the SE compensator..... I think something isn't right......
 

·
Registered
Joined
·
158 Posts
Same issue in my '12. Dealer told me it's common, and to "Keep an eye on it".

Never happened once on my '08 with the 103. Happens all the time on the new bike.

Thank God these bikes cost under $30,000! If they were expensive, I would expect some level of quality.
 

·
Enjoying a great Ride.
Joined
·
807 Posts
I remember my 07 did this noise because one of the compression releases would get stuck, it would make a hissing clicking noise, until I would give it a little throttle and it would pop up. On the Limited you have automatic com releases maybe one of them is getting stuck. I know they had that problem on the SE CVO bikes, just a thought.
 

·
Premium Member
Joined
·
1,790 Posts
Same issue in my '12. Dealer told me it's common, and to "Keep an eye on it".

Never happened once on my '08 with the 103. Happens all the time on the new bike.

Thank God these bikes cost under $30,000! If they were expensive, I would expect some level of quality.
@gree: :hystria: The quality could be better.. No more New Harley's for me. I'll go backwards from now on.. I'll still ride Harleys.

haven't heard much about the compression releases, good thought.
 

·
Registered
Joined
·
243 Posts
Seasoned Rider

ultra103's Avatar

Join Date: Jan 2008
Location: Arkansas
Posts: 85
ultra103 is on a distinguished road

Same issue in my '12. Dealer told me it's common, and to "Keep an eye on it".

Never happened once on my '08 with the 103. Happens all the time on the new bike.

Thank God these bikes cost under $30,000! If they were expensive, I would expect some level of quality.

So sad, but sooooooo true!
 

·
Premium Member
Joined
·
317 Posts
Ticking Noise

My 2010 Limited has the the tick . The trans was rebuilt and the SE comp is in it now a lot of noises went away with SE comp but the tick is still there.
Think it is a lifter, hopefully a new set of lifters with cam upgrade will cure all.
 

·
Registered
Joined
·
3 Posts
I have a 2010 96cc ultra classic and it is doing the same thing. Only 15K on it and it started around 11K. Took it to the dealership and they kept it for a week. They couldn't find the problem. I took it to an independent and they said it was probably a lifter but couldn't guarentee that would fix it. I suppose it's an issue with the newer made engines. Funny it's in both 96 and 103 newer engines.
 

·
Premium Member
Joined
·
1,809 Posts
I just saw a set of lifters yesterday out of a 2010 softail with 10k and the rollers looked really bad,this is not the first set to show pre-mature wear that I have seen.
I would pull them and give em a look...JMO
 

·
Premium Member
Joined
·
496 Posts
I just saw a set of lifters yesterday out of a 2010 softail with 10k and the rollers looked really bad,this is not the first set to show pre-mature wear that I have seen.
I would pull them and give em a look...JMO
Yea I'm glad I sent a set with the bike cause the local "a$$ clowns" would have slapped it back together w/o ever telling me!
 
1 - 19 of 19 Posts
Top