V-Twin Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Help Please.
Bought 2009 Superglide Custom last year. Installed new battery at time of purchase. Rode from July til Sept. Put trickle charger on it
at beginning of season and did not charge it again. Bike starts first time every time until 3 weeks ago. Rode two hours at all speeds mostly fast. End of ride stop to fill up with gas before calling it a day. Go to start up and nothing. not even a whir. Get AAA to bring the bike home. Trickle charge it overnight. Starts like a charm. Take it to Bike shot after three or 4 rides to get inspection and *make sure* you check charging system. Pick up bike the next day. They say everything is fine. Ride it to work. Get off work and jump on it to go home and battery wont turn over bike. Nobody wants to tow a bike at 5 pm on Fri night. Guy came from 60 miles away to do the job. Had called the Bike shop as soon as it happened and they said bring it back in. Anyone out there have similar experience and has a clue as to what the issue might be. Battery terminals are fine. Thanks for any help!
 

·
Registered
Joined
·
8,345 Posts
it's not charging,,, there are 3 components to the charging system.. rotor, stator and voltage regulator,, the system must be checked,, starting with the stator..
 

·
Registered
Joined
·
876 Posts
I would question the ability of your shop to diagnose the charging system. It's not that tricky. If they come up blank again look for another shop.
 

·
Registered
Joined
·
1,173 Posts
It takes 5 mins, a volt meter and s screw driver to check the charging system. Start bike remove seat (screwdriver) check volts at battery at 2k rpm. Below 13 Ohm the stator see if it’s grounded above 13.5 load test battery

Yea I over simplified but if you’re not able to diagnose a charging issue on these simple systems you shouldn’t be planning to fix yourself anyway.
 
1 - 7 of 7 Posts
Top