V-Twin Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone. I recently bought a 2002 Electra glide. When I first got it it ran OK every once a while it would miss or kind of stutter out the intake but it was nothing serious. Lately it has gotten a lot worse. When you start it up and let it idle it runs OK for a couple seconds then the RPMs seem to fluctuate around a lot and then eventually stalls out after 15 to 20 seconds. At stop signs you have to give it gas to keep it running. Top speed is around 75 to 80 miles an hour before it will bog out and seem to have no power. I replaced the spark plugs and wires as well as the TPS sensor thinking that’s what it may have been. Could this be a coil issue?
 

·
Registered
Joined
·
694 Posts
Is it carb or injected? You might want to run some fuel system cleaner through the tank. Sounds like a fuel delivery issue. Injected has the pump, regulator, and filter all located inside the tank. I don't know if the filter has a service life, I'm happily stuck in the carb days. Even the carb models have a filter on the petcock inside the tank. Something as simple as a fuel cap that doesn't vent properly can cause fuel delivery problems.

You don't give much history of the bike. Could have been sitting with fuel in the tank. That will cause issues. Also, it would help to know if there has been any equipment modifications you were told about or have identified since you bought the bike.
 
1 - 2 of 2 Posts
Top