V-Twin Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Any others with this problem? I noticed for about a year that the weld on the front tank mount was bleeding rust through the weld. I tried putting a dab of paint over this pinpoint spot. The rust would eventually bleed out.
I showed the folks at Northwest HD the problem. They decided the best thing was to order a new tank under warantee. OK with me but seemed like a bit of overkill. Well the tank arrived I took the bike in and had the new tank put on. Looked great up until I got home and started waxing the new tank. Couldn't believe my eyes when I went to wax the left side front tank mount tab. The weld holding the tab to the tank was cracked about 1" in length. The factory weld was barely on the tank at all. I am not a welder by any means but I'm positive I could have done better welds having looked at the rest of the welds on the under side of the tank. I took the bike back to HD and they couldn't believe the crappy weld job either. They said nobody else has brought in this problem. Could I be the only unlucky person to experiece the poor weld problem? especially twice! Oh well , they ordered another tank
should be a few more weeks. I wonder if I should have let the minor problem go? The service folks said I did the right thing by not letting a minor problem of rust turn into a major rot problem. HELL WHO KNOWS!!! Thanks for the great site for letting off some steam.
 

·
Premium Member
Joined
·
450 Posts
NO tank weld rotting trouble here, though my frame seems to drip rust water after a wash?!

If you had trouble, I have to believe that many others have as well, just a reailty in mass production.
 
1 - 2 of 2 Posts
Top