V-Twin Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
01 fxdp, hsr42 carb, twintec ignition. Under hard acceleration or even just trying to get out in the front of traffic, it shuts off and will start immediately if I turn the key off and back on.. I can usually catch it before it completely dies and ofcourse,. ... huge backfire. So is it possibly a bank angle sensor? A problem with my Ignition module? All grounds are tight. It's definitely not a mechanical issue but ignition or wiring obviously. I've had a couple different engines in the bike and it's done it with both of them.... hmm. Thanks in advance for any valuable advice on this matter.
 

·
Registered
2004 FLSTCI, 1993 FXDL
Joined
·
1,474 Posts
I though Bank Sensor when I read your post title. Maybe. But also maybe a crank position sensor. Since it's carbed it can't be throttle position I wouldn't think. Check all battery connections. Maybe something is moving when you accelerate. Hang in there more experienced people on here will chime in hopefully. And hopefully I won't get a "or not".
 

·
Registered
Joined
·
1,638 Posts
.... I've had a couple different engines in the bike ....
I'm guessing one of them was the original. What you got in there now? Looks kind of EVO to me. Unless your little avatar goes with a different bike or former life.
 
  • Like
Reactions: meandean4570

·
Registered
Joined
·
148 Posts
If your talking hard acceleration, I wouldn't be surprised if fuel float bowl height level was low. Typically it would run fine then under hard load or acceleration it pulls all the fuel out of the float bowl.. loud backfire would be consistent with this theory.
 
1 - 9 of 9 Posts
Top