V-Twin Forum banner
1 - 17 of 17 Posts

·
Premium Member
Joined
·
101 Posts
Discussion Starter · #1 ·
I am looking at buying a 01 Road King. I have read somewhere that the 01's have MM fuel injection , and that 02's and later have Delphi which is better? I have searched and can't find any details. What is the problem with the MM? Can it be easily fixed? Should I even worry about it?
 

·
Registered
Joined
·
365 Posts
The Magneti marelli EFI does not have a good reputation.
I believe that by then it was a Delphi. At least my 01 Deuce is a Delphi.
 

·
Registered
Joined
·
675 Posts
The '01 RK is the MM, and IMHO, there's not a thing wrong with it. You're much less dealer-dependent than with the Delphi, and you don't have to labor under Delphi's heat management system. If you want to build the engine, you can make good power, and the system accepts the Power Commander. Its main drawback is that if you want to make more than 110 hp, you're probably not going to do it.
Don't get me wrong, the Delphi is also a good system; it's more comlpex than the MM and measures things more finely, and it's gotten a lot of very good reviews. But if you're inclined to work on things yourself, the Delphi EFI system was one of the first of many steps in making the HD owner more dependent on the dealer. For example, only the dealer can set the idle on the Delphi.
If you've found a bike that you like, I wouldn't let the MM system stand in the way of getting it.

Ragnar
 

·
Registered
Joined
·
17 Posts
RAGNAR

That's positive to hear! I just purchased an 01'RK and BDOG1234 is thinking about it.

I didn't want to highjack BDOG1234's thread so I started a new one asking generally what was the difference was between 01 and 02+ TC88's and ECM's.
 

·
Premium Member
Joined
·
101 Posts
Discussion Starter · #6 ·
Thaks for the replies. Juscruzn, Hijack away! I have the same questions, after all we are looking at the same bike.
 

·
Registered
Joined
·
503 Posts
MM Fuel System

My 2001 Ultra,80,000 miles 94 HP 102 TQ all With MM ...also it is easier to dial in as it has two runners (no reversion)

Good Luck

Steve The Dyno Man :cheers:
 

·
Hellbound Train
Joined
·
5,595 Posts
The MM is a good system and with the new SERT, you have another option besides the Power Commander. For the record, anyone with a SERT can quite easily set the idle though I don't know why they would want to unless they have made mods that require re-tuning anyway.
 

·
Hopalong
Joined
·
314 Posts
The MM system is fine for stock or mild builds. If you have to have the max power, uglydougly at HTT posted a MM bike with 123 HP and 112 TQ, the heads, cam, TB, injectors, and fuel pressure regulator were changed. It was tuned with a MM RT.
Robin
It was a 95", BTW
 

·
Premium Member
Joined
·
389 Posts
I've got on 01 FLHRCi with the MM system. I've had it since new, and have put 22k miles on it (I know...lightweight). The sytem is transparent. It starts the first time every time. No issue at all.
 

·
Registered
Joined
·
3,992 Posts
I've got an '00 w/MM. The most complained about problem is idle creep, mostly fast idle creep. It's usually solved with locktite on the adj. screw. If that fails there's always the thumbscrew!

I had an issue with injector connections but that can happen with any of them.
 

·
Registered
Joined
·
247 Posts
01 FLH here with the MM. Near 60,000 miles developed leaking injectors but I think the was due to a faulty Race Fueler that froze em open. It also has both a crankshaft position sensor and a camshaft position sensor (I dont know the reason for 2 sensors doing the same job here). Still..all in all its been almost trouble free. Agreed...hot idle can creep on you but its really easy to adjust that yourself.
 

·
Premium Member
Joined
·
389 Posts
Tell me more about the fast idle creep! I thought it was just mine. It will go from 1000-ish rpm down to about 700 over a few months. I can't actually see the adjustment screw, so I'm a little skeert of backing it all the way out for the loctite treatment.

cwo2lt said:
I've got an '00 w/MM. The most complained about problem is idle creep, mostly fast idle creep. It's usually solved with locktite on the adj. screw. If that fails there's always the thumbscrew!

I had an issue with injector connections but that can happen with any of them.
 

·
Registered
Joined
·
3,981 Posts
OK, I struggled with my MM from early 03 when I bought my 01 FLTRI. Not that it had any problems, quite to the contrary! IT ALWAYS PERFORMED PERFECTLY!!!
My struggle was that I wanted to build my engine and at that time the MM had a bad rep with respect to hi performance builds.
I finally built my motor, rather pedestrian actually with 95" and tw37b cams and BigBoyz heads but, I also added a BC Gerolamy proted MM throttle Body.
Well, long story short, My bike has some of the best numbers around for this common build, with SAE adjusted 99+HP and 109+TQ and runs great, admitidly there were tuning issues following the build but nothing major in any way and talk about fun to ride!!! I have perma grin and stretched arms!!
For the record, I have never ever had any idle problems and I have 28k miles on it with about 700 on the new build which gets stronger every ride.
I would never hesitate reccomending MM to anyone. If you need 110+HP, you will need to address the fuel injection on delphi too, the gerolamy upgrade is about $300..... just my $.02
 

·
Registered
Joined
·
3,992 Posts
Sinker said:
Tell me more about the fast idle creep! I thought it was just mine. It will go from 1000-ish rpm down to about 700 over a few months. I can't actually see the adjustment screw, so I'm a little skeert of backing it all the way out for the loctite treatment.
Not sure whats to tell. The screw is behind the air cleaner plate and is a pain to get to but you can.

One other thing. According to the service manual, you do have one right?, you need to remove the fuse going to the ECM after you set the new idle speed. What it doesn't say is you need to pull the fuse as soon as you kill the engine. Don't wait for it to wind down, pull it as you shut it down. For some reason the ECM will not accept the new idle speed unless do it like that.
 

·
Registered
Joined
·
3,992 Posts
Dontdial911 said:
01 FLH here with the MM. Near 60,000 miles developed leaking injectors but I think the was due to a faulty Race Fueler that froze em open. It also has both a crankshaft position sensor and a camshaft position sensor (I dont know the reason for 2 sensors doing the same job here). Still..all in all its been almost trouble free. Agreed...hot idle can creep on you but its really easy to adjust that yourself.
All injection systems can have problems with sensors and injectors, I haven't heard of more failures in the MM systems as opposed to any other systems.
 
1 - 17 of 17 Posts
Top