2005 Ultra Classic Stereo won’t power on unless speaker switch is off : V-Twin Forum: Harley Davidson Forums
» Sponsors

Go Back   V-Twin Forum : Harley-Davidson Motorcycle Forums > Model Specific Discussion Forums > Harley-Davidson Touring
New User? Register Forgot Password

Reply
 
LinkBack Thread Tools Display Modes
Old 06-11-2019, 08:39 AM   #1 (permalink)
FNG :)
 
CookUltraClassi's Avatar
 
Join Date: Jun 2019
Location: Greene County Indiana
Posts: 3
CookUltraClassi wants to know Dino or Syn?
2005 Ultra Classic Stereo won’t power on unless speaker switch is off

I have an odd issue with my factory stereo that I can’t figure out.
First, the stereo will not power on when the ignition switch is turned to ignition like it should, or when the bike is running.
Once the bike is started, or switch in position, the stereo won’t power on. Not just in standby, but completely off. You have to flip the speaker rocker switch to the topmost position. All speakers off, and bam! Stereo powers on. Once its on, you can flip the rocker switch and turn the speakers on.
The second issue is the display is scrambled. You can JUST BARELY make out the volume level but it’s nearly impossible to read the display. Other than that, everything functions as it should. It works perfectly, other than the scrambled display, and not powering on unless the speaker switch is off.

I have the upgraded fairing speakers, and one of the soldered leads were pulled off of the small PCB when disconnecting the speaker leads. I resoldered it, and the speaker works fine, but that is the only issue I can think of that might have something to do with the speaker rocker switch affecting the unit powering on. Like I said, it functions perfectly otherwise.

Any idea on what could cause this? The scrambled display and power issue may be two separate issues. I plan to bend the pins of the display and check their connection between the head unit and display panel, but I’m stumped on the powering on issue.

Any help is much appriciated.

Thanks
CookUltraClassi is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-11-2019, 02:59 PM   #2 (permalink)
IronButt
 
Join Date: Sep 2015
Location: Central NY
Posts: 2,027
Greg_E wants to know Dino or Syn?
I'd guess bad power supply where it can't get enough current to power up when it is also trying to push to the speakers. Speakers off would be less power draw and might be a small enough inrush to allow things to power up. I'd get it serviced from a third party, there is one place that specializes in repairing Harley radios but I don't remember the name.
__________________
My miniGP racing stuff: http://minigp-racing.com
Greg_E is offline   Reply With Quote Quick reply to this message
Old 06-11-2019, 10:55 PM   #3 (permalink)
Make me use my bullet?
 
<G Man>'s Avatar
 
Join Date: Jun 2011
Location: Hominy Valley, Hillbillachia
Posts: 12,508
<G Man> joined the Live to Ride club <G Man> joined the Live to Ride club <G Man> joined the Live to Ride club <G Man> joined the Live to Ride club <G Man> joined the Live to Ride club
Iron Cross Audio Repair
http://www.ironcrossaudio.com/
__________________
G Man



Meddle not in the affairs of dragons for you are crunchy and taste good with ketchup.


Silence is golden , duct tape is silver.

Stay back 200 feet - not responsible for damaged feelings.

The biggest problem with social media is that it has caused so many people to falsely believe that someone gives a sht about their stupid-assed opinions.
<G Man> is offline   Reply With Quote Quick reply to this message
 
Old 06-12-2019, 09:59 AM   #4 (permalink)
IronButt
 
smitty901's Avatar
 
Join Date: Jul 2008
Location: WI
Posts: 2,862
smitty901 is still riding a stock bike smitty901 is still riding a stock bike
Iron cross to fix the radio if that is the problem. Go back remove all the work you did put it back as it was then try it. Most often that fixes things quickly.
__________________
Infantry leads the way
smitty901 is offline   Reply With Quote Quick reply to this message
Old 06-12-2019, 12:13 PM   #5 (permalink)
IronButt
 
Join Date: Jun 2014
Location: lost but not found or dazed and confused
Posts: 7,963
tall terry is still riding a stock bike tall terry is still riding a stock bike
listen to smitty always flow. backwards from the most recent to oldest work when chasing electronics....
both sircuits feed off the auxiliary harness,,, from the ignition switch. it could be a high resistance,,, bad connection, etc all you need is volt ohms amp meter and a test light... there are some really functional tools available for diagnostics literally plug and play
...
tall terry is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the V-Twin Forum : Harley-Davidson Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. WE WILL SEND A CONFIRMATION EMAIL TO THE ADDRESS YOU PROVIDE. If the email address is NOT VALID, you will not be given access to the system!
Email Address:
Motorcycle Year/Make
Location
Where you live
Security Question
*Required, this field is not shown to others: While balancing on a piece of wood, two inches by four inches known as a 2x4, john and his friend sally both spotted a dalmatian inside a truck with sirens, headed to put out a fire. State what kind of animal is mentioned in the sentence above.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear Brake light won’t light up 716shovelhead Electrical, Wiring and Lighting 8 Today 08:04 AM
2005 Ultra Stereo won’t power on unless speaker switch off CookUltraClassi Electrical, Wiring and Lighting 1 06-11-2019 08:48 AM
96 Sportster fuse is clicking; bike won’t start gnar_nasty Harley-Davidson Sportster 3 11-01-2018 04:30 AM
Won't start unless in Neutral ABQ-Jammer Harley-Davidson Dyna 2 01-16-2018 05:41 PM
won't idle unless choked. can anyone help? 96XLH883_820 Harley-Davidson Sportster 8 03-25-2010 09:49 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:07 PM.


Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(C)2001-2012 V-twinForum.com All Rights Reserved (C)2001- V-twinForum.com All Rights Reserved
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Victory Charger Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum